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A Reminder 
on System 
Requirements 

Please install all critical and recommended updates for your operating system and Internet 
Explorer. It is imperative that all critical and recommended updates are installed in a timely fashion. These updates are 
provided to help resolve known issues and protect your computer from known security vulnerabilities.  
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Introduction to System Administration 
 

Welcome! 

 Welcome to Communicator! NXT system administration.  There are numerous applications that 
reside in the RxT system that do not require manipulation from System Administrators or end 
users.  This guide addresses those applications that requires a system administrator to interface with 
to maintain optimal system performance. 
 
During the installation process, DCC software technicians will perform all necessary system 
configurations required during the initial setup for Communicator! NXT.  They will guide you 
through applications and processes that must be conducted at the server.  This book will coincide 
with these processes, reassuring system administrators have a complete knowledge base of the 
server and have all the necessary tools to support Communicator! NXT. In addition, DCC 
Technical Services is available to provide assistance in troubleshooting problems and answering 
system related questions. 
 
This material includes two sections with related applications: 

 RxT Client Monitors includes the following applications 
 Email Monitor 
 Pager Monitor 
 Phone Monitor 

 
 Utilities includes the following application 

 Line Configuration 
 
 

About the RxT Client Monitors and Utilities 

 The RxT Client Monitor and Utility applications are components of RxT, DCC's patented 
notification technology.  Both the Frontwave IVR ™ system and the Communicator! NXT
system use these applications.  

Each RxT Client Monitor or Utility application can be customized to meet the needs of your 
organization.  Configuring the options available for the application will determine how your users 
interface with the system. 

 Note:  There are numerous applications that reside in the RxT system that do not require manipulation from 
System Administrators or end users.  During the installation process, DCC software technicians will 
perform all necessary system configurations required during the initial setup for Communicator! NXT and 
Frontwave IVR.  In addition, DCC Technical Services is available to provide assistance in troubleshooting 
problems and answering system related questions. 
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Email Monitor 

 

The Email Monitor application can be used to monitor email communications.  Communicator! NXT can 
view the email notification log for email messages sent to contacts included in an activation, as well as, 
individuals receiving reports of scenario activity via email.  Although this application monitors the email 
activity, it is not the service that physically sends email messages.  The email messages are sent via the Email 
Net Service that runs in the background of RxT.  The Email Monitor is, however, capable of initiating and 
shutting down the Email Net Service. 

Pager Monitor 

 

The Pager Monitor application can be used to monitor pager communications.  Communicator! NXT can 
view the pager notification log for pager messages sent to contacts included in an activation.  Although this 
application monitors the pager activity, it is not the service that physically sends pager messages.  The pager 
messages are sent via the Pager Net Service that runs in the background of RxT.  The Pager Monitor is, 
however, capable of initiating and shutting down the Pager Net Service. 

Phone Monitor 

 

The Phone Monitor application can be used to monitor phone communications and monitor phone line 
status.  It also allows the user to configure setting related to call routing, information logging, etc. 
Communicator! NXT can view the phone notification log for phone messages sent to contacts included in 
an activation.  Although this application monitors the phone activity it is not the service that physically sends 
phone messages.  The phone messages are sent via the Voice Net Service that runs in the background of 
RxT. 

Line 
Configuration 

 

The Line Configuration application can be used to set the dialing rules and properties for outbound calling.  
This application allows the user to modify phone line settings by configuring individual telephone line 
Groups and to define the format used when outbound numbers are dialed by customizing Dialing Rules.  A 
Do Not Call List is also available to allow users to exclude phone numbers that should not be called. 

 
 
The DCC Menu 
 

 

The main menu screen displays thumbnail options in the left hand pane for navigating through the system’s 
menu.  These topics control the applications that will be displayed in the right hand pane.  The right hand 
pane displays icons that allow you to access each of the individual applications. 
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Email Monitor 
     

 
What Is Email Monitor? 

 The Email Monitor application is a component of RxT.  Both the Frontwave IVR™ 
system and the Communicator! NXT system can use this application to monitor email 
communications.  Frontwave can use this application to view the email log for messages 
sent for certain situations (e.g., outage notifications via the Outage Processor 
application, etc.).  Communicator! NXT can view the email notification log for email 
messages sent to contacts included in an activation, as well as, individuals receiving 
reports of scenario activity via email.  Although this application monitors the email 
activity, it is not the service that physically sends email messages.  The email messages 
are sent via the Email Net Service that runs in the background of RxT.  The Email 
Monitor is, however, capable of initiating and shutting down the Email Net Service. 

Typically, the Email Monitor application will be used to troubleshoot problems by DCC 
personnel.   

Email Monitor application allows you to: 
 Customize Email Net Service options (which debug messages to display, where to log 

activity, etc.). 
 Connect to different machines to monitor activity. 
 Suspend/Resume logging activity within the application. 
 Clear the display window. 
 Shutdown the Email Net Service to terminate all email activity. 
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How Do I Access the Email Monitor Application? 

 
 

The Email Monitor email notification log for email messages sent to contacts included in an 
activation, as well as, individuals receiving reports of scenario activity via email. Although this 
application monitors the email activity, it is not the service that physically sends email messages. 
Email messages are sent via a service application that runs in the background of RxT. The 
Email Monitor is, however, capable of initiating and shutting down the Email Net Service. The 
Email Monitor application is typically used to troubleshoot problems. 
Access the Email Monitor application to inspect the activity of this service.  The display area 
allows users to interface with the activity log. 
 

 Steps to Access the Email Monitor Application: 
1. Double click the DCC Menu icon on the Desktop. The Login screen displays. 
2. At User Name, type the name, and then press Tab.  
3. At Password, type the password, and then click OK.  The DCC Menu displays. 
4. Click RxT Client Monitors located in the left hand pane.  The window on the right will display a 

variety of icons. 
5. Click the Email Monitor icon located in the right hand pane.  The Email Monitor screen displays. 

 

 

 

 

 

 

 

 

 

 

Figure 1:  Select the DCC Menu 
Icon on the Desktop.  The Login 
dialog box displays.  Type your User 
Name and Password and click OK.  
The DCC Menu displays. Click RxT 
Client Monitors located in the left 
hand pane, and then click the Email 
Monitor icon located in the right 
hand pane. The application opens, 
and the Email Monitor window 
displays. 
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About the Work Area 

 When the Email Monitor application is launched a variety of screen components display.  The 
applications window will display a: 

 Title bar displaying the name of the application,  Email Monitor – xxx (where xxx is the name 
of the machine or server configured to monitor email activity). 

 Menu bar options provide an easy way of accessing functions available in Email Monitor.   
 

Figure 2:  The Email 
Monitor application 
window contains a variety 
of screen components.  
 

 

 

 

 

 

 

 
      
 
Resize Columns The display area in the Email Monitor application can be manipulated and tailored to your preferences.   

 To Resize point to a vertical column line between column titles.  The cursor will change to display 
.  Press, hold and drag the column line to desired size. 

 

Figure 3: Columns can 
be resized within the 
Email Monitor 
application.  

 

 

Resize columns by dragging the vertical 
line dividing column titles to desired size. 

Title Bar 
Menu Bar 

The preview pane 
displays information
about the email log. 



 
SYSTEM ADMINISTRATION: EMAIL MONITOR 

 --88-- Doc 4.x 

             
Menu Bar  The menu bar is located at the top of the Email Monitor main window and consists of several 

menu options.  When one of the menu options is selected, a dropdown menu will display that 
provides a listing of additional actions that can be performed.  The following menu options are 
displayed on the menu bar: 

File Menu The File menu provides the ability to exit or shutdown the Email Monitor application. 

Tools Menu The Tools menu provides the ability to set email options, switch to a different server or machine or close 
on detach. 

 Help Menu The Help menu allows you to view information about the installed version of Email Monitor. 
 

Figure 4: The Email 
Monitor main window 
displays available menu 
options.  The menu bar 
options provide a way of 
accessing functions.  Select 
the desired menu to display 
options that relate to the 
chosen menu.  

 

 

 

 

 

  
The Display Area  The display area shows columns of information that include: 

 Date – the date of the listed activity. 
 Time – the time of the listed activity. 
 Type – the identifier for the communication component (e.g., an Information, Debug, etc. 

message type). 
 Source – the identifier that points to the source code that allows the DCC developers to 

troubleshoot any problems. 
 Message – describes the listed activity. 

 Note:  If you right click anywhere in the display area a menu will display allowing you to Clear 
the display area of all messages or Suspend/Resume logging activities. 
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Shutdown the Email Net Service 

 Steps to Shutdown the Email Net Service: 
1. At the Email Monitor window, click File > Shutdown.  The Email Monitor window will display 

with a Warning message. 

Shutdown The Shutdown option will shutdown the Email Net Service.  Emails will not be sent if the Email Net 
Service is down. 

 2. At the Warning message, click Yes to shutdown the Email Net Service or click No to cancel the action.
 

Figure 5:  To shutdown the 
Email Net Service click 
File > Shutdown.  At the 
Warning message click 
Yes to shutdown the Email 
Net Service or click No to 
cancel the action.  Emails 
will not be sent if the Email 
Net Service is down.  
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Customize Email Options 

 The Email Options screen displays four areas where settings can be configured: General, 
Logging, Debug and Testing.  

 
Access Email 
Options 

Steps to Customize Email Options: 
1. Click Tools > Options.  The Email Options screen will display defaulting to the General tab. 

 
General Options Steps to Customize General Options: 

 1. At Enabled, click the checkbox to select  or click again to deselect . 

Enabled The Enabled feature must be checked to enable Email Net Service.  If this option is not selected, emails 
will not be sent during designated notifications. 

Email clients Email clients indicates the number of virtual email clients the Email Net Service can use. This allows 
multiple emails to be sent at one time. 

Tasks per email Tasks per email designates the number of recipients per email. This allows the Email Net Service to send 
emails in batches. 

 2. At Return Email Address, click the text box and type desired email sender information. 

Return Email 
Address

The Return Email Address is a required field.  The email address that is entered displays as the From 
address on email messages sent from this server. 

3. Click OK to accept the selected options and return to the Email Monitor window.  Click Apply to accept 
the selected options and leave the Email options window open.  Click Cancel to close the window 
without saving any changes. 

 
Figure 6:  To customize 
email options, click Tools 
> Options to display the 
Email Options window.  
Make desired selections, 
and then click OK to save 
your changes and close the 
window.  At the General 
options tab, complete 
desired settings related to 
the Email Net Service. 
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Logging Options Steps to Customize Logging Options: 

 1. Click the Logging tab to display options. 

 2. At Log to event log, click the check box to select  or click again to deselect . 

Log to event log The Log to event log enables any activity that occurs to be logged into the Windows Systems Application 
Event Log.  This log option is typically disabled. 

 3. At Log output file, click the checkbox to select  or click again to deselect . 

Log output to file The Log output to file enables any activity that occurs to be logged to a text file. If this option is selected, 
at the File to log to text box type the path and file name or click the More button to access the Open 
dialog box where a file location and name can be entered.  This log option is typically disabled as the 
Email Monitor logs activity to the RxT Server log. 

Log separate devices If enabled, the Log separate devices will group Email Service activity/debug messages by Email Client. 

 4. At Log buffer size, click the text box and type in the number representing the buffer size. 

Log buffer size The Log buffer size defines the size of the storage area to hold log messages. 
5. Click OK to accept the selected options and return to the Email Monitor window.  Click Apply to accept 

the selected options and leave the Email options window open.  Click Cancel to close the window 
without saving any changes. 

 
Figure 7:  At the Logging 
options tab, complete 
desired settings related to 
logging activity (e.g., 
system, debug messages, 
general information, etc.).  

 
 



 
SYSTEM ADMINISTRATION: EMAIL MONITOR 

 --1122-- Doc 4.x 

 
Debug Options Steps to Customize Debug Options: 

 1. Click the Debug tab to display options. 

 2. At Enable debug messages, click the checkbox to select  or click again to deselect .  Once this setting 
is selected the System, RxT and Mail options become active and available for selection. 

Enable debug 
messages

The Enable debug messages setting is used exclusively by DCC for troubleshooting problems. System 
Administrators should not utilize this feature unless instructed by Technical Services.  System will send 
debug messages related to supporting the system (e.g., file access, system resources, etc.); RxT will send 
debug messages related to the communications layer between the Email Net Service and the RxT service; 
and Mail will send messages related to the transmission of email messages.  

 3. Click OK to accept the selected options and return to the Email Monitor window.  Click Apply to accept 
the selected options and leave the Email options window open.  Click Cancel to close the window 
without saving any changes. 

 
Figure 8:  At the Debug 
options tab, complete 
desired settings related 
capturing debug messages. 
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Testing Option Steps to Customize Testing Options: 

 1. Click the Testing tab to display options. 

 2. At Use test addresses, check this box to override all emails sent by the Email Net Service to the email 
addresses listed. 

  To Add an email address to the list, click Add, type a valid email address, and then press Enter. The 
address is added to the listing. 

  To Delete an email address from the list, click to select the desired email address, and then click 
Delete. At the Confirm delete items message, click Yes. The selected email address is removed 
from the listing. 

 3. Click OK to accept the selected options and return to the Email Monitor window.  Click Apply to 
accept the selected options and leave the Email options window open.  Click Cancel to close the 
window without saving any changes. 

 
Figure 9:  At the Testing 
options tab, complete 
desired settings related to 
sending test email 
messages.  
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Close on Detach 

Using the Tools > Close on Detach options gives you the ability to detach the Email Monitor 
from the Email Net Service. By default, the Email Monitor will close when the Email Net 
Service is unavailable or is Shutdown. 
 

 

 

Steps to Close on Detach: 

 1. Click Tools > Close on Detach.  The check mark is removed (the option disabled). Repeat this process
to enable this setting. 

 
    

Access a Different Machine 
Using the Tools > Machine options gives you the ability to access a different machine or server 
to monitor the activity taking place. 
 

 

 

Steps to Access a Different Machine: 

 1. Click Tools > Machine.  The Enter the name of machine to monitor window will display. 

 2. At Machine Name, click the text box to select and type the name of the machine or server. 

 3. Click OK to connect to the defined machine (a message will display stating ‘Attaching to Service…’) 
or click Cancel to abort the action. 

 
Figure 10:  To access a 
different machine to 
monitor email activity, click 
Tools > Machine.  The 
Enter the name of 
machine to monitor 
window displays.  At 
Machine Name, click the 
text box to select and type 
the name of the machine or 
server.  Click OK to 
connect to the defined 
machine.  
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Suspend/Resume Logging 

If you right click anywhere in the display area a menu will display allowing you to Clear or 
Suspend/Resume Logging (this option will act as a toggle between the 2 options).  Suspend 
Logging will pause the Email Monitor from posting activity to the display area. 
 

 
 

Steps to Suspend Logging: 

 1. Right click anywhere in the display area.  A menu will display. 

 2. Click Suspend Logging.  The Email Monitor will stop posting activity to the display area. 

 3. Right click anywhere in the display area.  A menu will display. 

 4. Click Resume Logging.  The Email Monitor will restart posting activity to the display area. 
 
Figure 11:  Right 
anywhere in the display 
area to display a menu.  
The Suspend/Resume 
Logging option will act as 
a toggle depending on the 
current state of the display 
area.  Click 
Suspend/Resume 
Logging to activate that 
option.  
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Clear the Display Area 

If you right click anywhere in the display area, a menu will display allowing you to Clear or 
Suspend/Resume logging from the main screen.  The Clear option will clear all message from 
the display area. 
 

 
 

Steps to Clear the Display Area: 

 1. Right click anywhere in the display area.  A menu will display. 

 2. Click Clear.  The Email Monitor display area will clear all messages. 

 Note:  To view the messages again after they have been cleared, click Tools > machine name 
(listed at the bottom of the Tools menu). 

 
Figure 12:  Right 
anywhere in the display 
area to display a menu.  
Click Clear.  All 
messages will be removed 
from the display area.  
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Exit the Email Monitor Application 

 
To close the Email Monitor application, select Exit from the File menu or select the close icon 
located on the upper right of the title bar. 

 
Steps to Exit the Email Monitor Application:  
1. At the Email Monitor screen, click the File menu then click Exit (or click  on the upper right of the 

title bar. 
 

Figure 13:  To exit the 
Email Monitor 
application, click the close 
button on the upper right 
of the title bar or select 
File > Exit. 
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Pager Monitor 
     

 
What Is Pager Monitor? 

 The Pager Monitor application is a component of RxT.  Both the Frontwave IVR™ system 
and the Communicator! NXT system can use this application to monitor pager 
communications.  Frontwave can use this application to view the pager log for messages sent for 
certain situations (e.g., outage notifications via the Outage Processor application, etc.). 
Communicator! NXT can view the pager notification log for pager messages sent to contacts 
included in an activation.  Although this application monitors the pager activity, it is not the 
service that physically sends pager messages.  The pager messages are sent via the Pager Net 
Service that runs in the background of RxT.  The Pager Monitor is, however, capable of 
initiating and shutting down the Pager Net Service. 

Typically, the Pager Monitor application will be used to view pager activity and troubleshoot 
problems.   

Pager Monitor application allows you to: 
 Customize Pager Options 
 Enable/Disable lines and stop active calls 
 Connect to different machines or servers to monitor activity 
 Suspend/Resume logging activity within the application 
 Clear the display window 
 Shutdown the Pager Net Service to terminate all pager activity. 



 
SYSTEM ADMINISTRATION: PAGER MONITOR 

 --2200-- Doc 4.x 

   
 
How Do I Access the Pager Monitor Application? 

 
 

The Pager Monitor is used to monitor pager communications for both Frontwave and 
Communicator! NXT.  Pager messages are sent via a service application that runs in the 
background of RxT. Access the Pager Monitor application to inspect pager activity.  The 
display area allows users to interface with the activity log. 

 

 Steps to Access the Pager Monitor Application: 
1. Double click the DCC Menu icon on the Desktop. The Login screen displays. 
2. At User Name, type the name, and then press Tab.  
3. At Password, type the password, and then click OK.  The DCC Menu displays. 
4. Click RxT Client Monitors located in the left hand pane.  The window on the right will display a 

variety of icons. 
5. Click the Pager Monitor icon located in the right hand pane.  The Pager Monitor screen displays. 

 

 

 

 

 

 

 

 

 
Figure 14:  Select the DCC 
Menu Icon on the Desktop.  
The Login dialog box displays.  
Type your User Name and 
Password and click OK.  The 
DCC Menu displays. Click UN 
Client Monitors located in the left 
hand pane then click the Pager 
Monitor icon located in the right 
hand pane. The application opens 
and the Pager Monitor window 
displays. 
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About the Work Area 

 When the Pager Monitor application is launched a variety of screen components display.  The 
applications window will display a: 

 Title bar displaying the name of the application,  Pager Monitor – xxx (where xxx is the name of 
the machine or server configured to monitor pager activity). 

 Menu bar options provide an easy way of accessing functions available in the Pager Monitor 
application. 

 
Figure 15:  The Pager 
Monitor application 
window contains various 
menu options to help 
manage and work with the 
selected activity.   

 
 

 

 

 

 

 

       
Resize Columns The display area in the Pager Monitor application can be manipulated and tailored to your preferences.  

 To Resize point to a vertical column line between column titles.   The cursor will change to display 
.  Press, hold and drag the column line to desired size. 

 Note:  Use the scroll bar located at the bottom of the screen to view all available information. 

 
Figure 16: Columns can 
be resized within the 
Pager Monitor 
application. 

 
Resize columns by dragging the vertical line 
dividing column titles to desired size. 

Title Bar 
Menu Bar 

The top pane 
displays information 
about the configured

device. 

The bottom pane 
displays information 

concerning the 
activity being logged 

for a selected 
device. 
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Menu Bar  The menu bar is located at the top of the Pager Monitor main window. The following menu 

options are displayed on the menu bar: 

File Menu The File menu provides the ability to exit, stop active calls, disable or enable lines or shutdown the Pager 
Monitor application. 

Edit Menu The Edit menu provides the ability to edit a selected line. 

Tools Menu The Tools menu provides the ability to set pager options, switch to a different server or machine to monitor, 
view function statistics or view the current machine. 

 Help Menu The Help menu allows you to view information about the installed version of Pager Monitor. 
 

Figure 17: The Pager 
Monitor main window 
displays available menu 
options.  The menu bar 
options provide a way of 
accessing functions. Select 
the desired menu to display 
options that relate to the 
chosen menu.  
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The Display Area  The display area shows columns of information that include: 

The Top Pane displays the actual phone lines that send alphanumeric messages.  Lines can be 
enabled, disabled, debugged and configured. 

 Device – the assigned line number of the device will display along with an icon of the device 
type. 

 Name – the name associated to the displayed device. 

 Modem – the state of the modem device (e.g., Open, Match, Flash, Quiet, Closed, etc.). 

 Status – the status of the device (e.g., Ready and Waiting for calls, Initializing Modem, Calling 
Pager Service, Waiting, Sending, Delaying, Active, Idle, Closed, Out of service, etc.). 

 
 The Bottom Pane displays a log of activity that has occurred or is occurring during a call.  Logs 

can be cleared or logging activity can be suspended / resumed. 
 Date – the date of the listed activity. 

 Time – the time of the listed activity. 

 Line – the phone line number for the activity being logged. 

 Source – the identifier that points to the source code that allows the DCC developers to 
troubleshoot any problems. 

 Message – describes the activity occurring. 

 Note:  If you right click anywhere in the bottom pane a menu will display with options to Clear the 
display area of all messages and Suspend/Resume Logging activities. 
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Working with the Pager Monitor 

 The Pager Monitor application can be used to stop active calls, enable or disable lines, 
shutdown the Pager Net Service, configure line settings, customize pager options, view function 
statistics, Suspend/Resume logging, and switch to different server to view activity.  An example 
of a pager activity might be: 

 Messages sent for certain situations (e.g., outage notifications via the Outage Processor 
application, notification that the host is down, etc. by the Frontwave system). 

 Pager messages sent to contacts during a scenario activation by the Communicator! NXT 
application. 

 
Stop Active Calls Stop Active Calls will terminate all active callflows and hang up the phone lines for all listed 

devices. 
 

 Steps to Stop Active Calls: 

 1. At the Pager Monitor window, click File > Stop Active Calls or right click in the top pane to display a 
menu and click Stop Active Call.  The Pager Monitor window will display with a Warning message. 

 2. At the Warning message, click Yes to stop placing phone calls or click No to cancel the action. 
 

Figure 18:  To stop all 
active calls, click File > 
Stop Active Calls.  At the 
Warning message, click 
Yes to stop calls or click 
No to cancel the action. 
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Disable / Enable 
Lines 

Disable lines will prevent all the listed phone lines from making new calls.  An indicator will 
display next to the device icon to represent the lines are down.  Enable Lines will reactivate the 
connection so new phone calls can be made. 
 

 Steps to Disable Lines: 
1. At the Pager Monitor window, click File > Disable Lines.  The Pager Monitor window will display 

with a Warning message. 
2. At the Warning message, click Yes to disable all the listed phone lines or click No to cancel the action. 

 

 Steps to Enable Lines: 
1. At the Pager Monitor window, click File > Enable Lines.  The phone lines will be activated. 

 
Figure 19:  To disable the 
phone lines, click File > 
Disable Lines.  At the 
Warning message, click 
Yes to disable the phone 
lines or click No to cancel 
the action.  Disable lines 
will prevent all the listed 
phone lines from making 
new calls.  

To enable the disabled 
phone lines, click File > 
Enable Lines.  The phone 
lines will be activated.  
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Shutdown the Pager 
Net Service 

Steps to Shutdown the Pager Net Service: 
1. At the Pager Monitor window, click File > Shutdown.  The Pager Monitor window will display 

with a Warning message. 

Shutdown The Shutdown option will shutdown the Pager Net Service.  Pager messages will not be sent if the 
Pager Server is down. 

 2. At the Warning message, click Yes to shutdown the Pager Server or click No to cancel the action. 
 

Figure 20:  To shutdown 
the Pager Net Service, click 
File > Shutdown.  At the 
Warning message, click 
Yes to shutdown the Pager 
Server or click No to cancel 
the action.  Pagers will not 
be sent if the Pager Server 
is down.  
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Edit a Line Steps to Edit a Line: 

1. Click to select the desired device in the top pane. 
2. Click Edit > Line or right click in the top pane to display a menu and click Edit.  The Modify Settings 

for Device: xxx window will display, where xxx is the name of the selected device. 

Device, Name The Device will list the line number for the selected pager Name. 

3. At Place outbound calls, click the check box to select  or click again to deselect . 

Place outbound calls The Place outbound calls option must be checked to enable outbound calls to be made by the Pager Net 
Service.  If this option is not selected, outbound pager calls will not be sent.  

4. At Receive inbound calls, click the check box to select  or click again to deselect . 

Receive inbound
calls

The Receive inbound calls option is currently not supported by Communicator! NXT or by the 
Frontwave application. 

Direct connection Direct connection is used by DCC for testing purposes.  

In Script Inbound call flow script is used by DCC for testing purposes. 

5. At Device Profiles, click the radio button to select one of the listed profiles. 

Device Profiles The Device Profiles allows different configuration settings to be saved for the selected paging device. 

6. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 
accept the selected options and leave the Modify Settings for Device window open.  Click Cancel to 
close the window without saving any changes. 

 Note:  This activity is done during systems installation and should not be changed.  If you have any 
questions, please contact DCC Technical Services for assistance. 

Modify The Modify button allows access to the Modify pager profile xx screen to configure settings for the 
selected pager device. 

Clear The Clear button will reset the selected Device profile to the default values. 
 

Figure 21:  To edit a line, 
click Edit > Line to display 
the Editing Device xxx 
window.  Make desired 
selections, and then click 
OK to save your changes 
and close the window.  
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Modify a Device 
Profile 

Steps to Modify a Device Profile: 
1. Click to select the desired device in the top pane. 
2. Click Edit > Line or right click in the top pane to display a menu and click Edit.  The Modify Settings 

for Device: xxx window will display, where xxx is the name of the selected device. 
3. Click Modify.  The Modify pager profile window displays showing the following options that are used 

to setup device dialing configurations – Out Initialize, In Initialize, Dial command, Hang up and the 
Communication Settings - Baud Rate, Parity, Data Bits, and Stop Bits.  These are configured so the 
paging device can talk to the pager receiving the message. 

 Note:  This activity is done during systems installation and should not be changed.  If you have any 
questions, please contact DCC Technical Services for assistance. 

4. Click OK to accept the selected options and return to the Modify Settings for Device: xxx window.  
Click Apply to accept the selected options and leave the Modify Pager profile window open.  Click 
Cancel to close the window without saving any changes. 

 
Figure 22:  To access the 
Modify pager profile 
screen, click the Modify 
button on the Modify 
Settings for Device: xxx 
window.   Make desired 
selections, and then click 
OK to save your changes 
and close the window.  
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Customize Pager 
Options 

Select Options from the Tools menu to access the Pager Options screen.  The Pager Options 
screen displays a variety of Tabs that organize related options into a logical display.  Select the 
desired tab heading to bring that screen to the front. 
 
Steps to Access Pager Options: Access Pager 

Options 1. At the Pager Monitor window, click Tools > Options.  The Pager Options window displays 
defaulting to the Logging tab. 

     
The Logging Tab The Logging tab allows you select where the activity information will be recorded.  You can 

select one or more options (e.g., log activity to an event log, to a text file, etc.), in addition to, 
defining the amount of items to log by determining the buffer size. 
 

 Steps to Customize Options on the Logging Tab: 

 1. Click to select the Logging tab to bring this screen to the front, if necessary. 

 2. At Log output to event log, click the check box to select  or click again to deselect . 

Log output to event log The Log output to event log enables any activity that occurs to be logged into the Windows Systems 
Application Event Log.  This log option is typically disabled. 

 3. At Log output to a file, click the checkbox to select  or click again to deselect . 

Log output to a file The Log output to file enables any activity that occurs to be logged to a text file. If this option is 
selected, at the File to log to text box type the path and file name or click the More button to access 
the Open dialog box where a file location and name can be entered.  This log option is typically 
disabled as the Email Monitor logs activity to the RxT Server log. 

Log separate devices If enabled, the Log separate devices will group Email Service activity/debug messages by Email 
Client. 

 4. At Log buffer size, click the text box and type in the number representing the buffer size. 

Log buffer size The Log buffer size defines the size of the storage area to hold log messages. 
5. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 

accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes. 

 

 continued… 
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Figure 23:  To access the 
Pager Options screen, 
click Tools > Options.  
The Pager Options 
window displays.   The 
Logging tab displays as a 
default.  Make desired 
selections on the Logging 
screen, and then click OK 
to save your changes and 
close the window.  
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The Debug Tab The Debug tab allows the selection of specific type of messages that will display when logging 

pager message activity.  In addition, it allows the option to choose to collect Function Statistics. 

 Note:  This screen and steps are provided for illustration purposes only.  Debug activity is performed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Debug Tab: 
 1. Click to select the Debug tab to bring this screen to the front. 
 2. At Enable debugging messages, click the check box to select  or click again to deselect .  When 

selected, the types of messages options become active and selectable. 

Enable debug messages The Enable debug messages setting is used exclusively by DCC for troubleshooting problems. System 
Administrators should not utilize this feature unless instructed by Technical Services.  System will send 
debug messages related to supporting the system (e.g., file access, system resources, etc.). RxT will 
send debug messages related to the communications layer between the Pager Net Service and the RxT 
service; and Line and Modem will send messages related to the transmission of pager messages.  

 Collect Function Statistics and Debug on lines are reserved for use by DCC. 
 3. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 

accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 24: Click the 
Debug tab to bring this 
screen to the front. Make 
desired selections on the 
Debug screen, and then 
click OK to save your 
changes and close the 
window.  
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The Test Numbers 

Tab 
The Test Numbers tab allows test numbers to be set up for the system to call versus live 
messages when making outbound calls.  This is primarily used when someone needs to 
troubleshoot or test the system (e.g., a new device was added and needs to be tested, etc.). 

 Note:  This screen and steps are provided for illustration purposes only.  Test Number activity is 
performed by DCC Technical Services and the development team to troubleshoot problems and answer 
system related questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Test Numbers Tab: 
 1. Click to select the Test Numbers tab to bring this screen to the front. 

 2. At Use test numbers, click the check box to select  or click again to deselect . 

Use Test Number Use test numbers indicates the system will call numbers from the test number list whenever it makes 
outbound calls.  This primarily used when someone needs to troubleshoot the system or has added a 
new device that needs testing and does not want live messages sent. 

 3. At Test Number Option, click  and select Sequential or By line number.  

Test Number If Sequential, the system will use the line numbers in sequential order when assigning test numbers to 
be called. For example, if there are 2 lines and 3 test numbers, and line number 1 is assigned number 
1111, line number 2 is assigned number 2222, then line number 1 is assigned number 3333. 
If By line number, the system will assign 1 test number to each line. For example, if there are 2 lines 
and 3 test numbers, and line number 1 is assigned number 1111, line number 2 is assigned number 
2222, then number 3333 is not assigned and, therefore, never called. 

 4. Add Test Phone Numbers:  
 Click Add.  The cursor will display in the Test numbers pane. If numbers already exist, then the 

next sequential number will be copied to a new line and highlighted. 
 Type the desired phone number and press Enter.  The number has been added to the listing.  

 5. Delete Test Phone Numbers:  
 Click to select one or more test phone numbers listed in the Test numbers pane.  
 Click Delete, and then click Yes at the confirmation message.  The numbers are removed. 

 6. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 
accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 25:  Click the Test 
Number tab to bring this 
screen to the front.   Make 
desired selections on the 
Test Numbers screen then 
click OK to save your 
changes and close the 
window.  
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The FSL Tab The FSL, or Flying Scripting Language (an interpreted language), tab is used by DCC Technical 

Services and the development team for troubleshooting system problems.  This screen provides 
options to - Allow FSL debugging, Force breakpoint on start, Force breakpoint on errors, 
Breakpoints, Debug Lines and FSL Timeout. 

 Note:  This screen and steps are provided for illustration purposes only.  FSL activity is performed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to View Options on the FSL Tab: 
 1. Click to select the FSL tab to bring this screen to the front. 

 2. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 
accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 26:  Click the FSL 
tab to bring this screen to 
the front.   Make desired 
selections on the FSL 
screen, and then click OK 
to save your changes and 
close the window.  
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The Lines Tab The Lines tab allows you to define the connect timeout timeframe in seconds, the modem 

initialization string (outbound and inbound), the modem dial command and delay after call 
timeframe. 

 Note:  This activity is done during systems installation and should not be changed.  If you have any 
questions, please contact DCC Technical Services for assistance. 

 

 Steps to Customize Options on the Lines Tab: 
 1. Click to select the Lines tab to bring this screen to the front. 

 2. At Connect timeout, click the text box and type the number of seconds. 

Connect timeout The Connect timeout indicates the number of seconds the system will allow for connecting to the 
device. If a connection is not made within the number of designated seconds, the line will be reset. 

 3. For changing values at the Modem out or in initialization, Modem dial command and Delay after call 
fields - please contact DCC Technical Services for assistance. 

 4. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 
accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 27:  Click the Lines 
tab to bring this screen to 
the front.   Make desired 
selections on the Lines 
screen, and then click OK 
to save your changes and 
close the window.  
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The Alerts Tab The Alerts tab allows you to define in what situations you want alert messages sent.  Alerts are 

sent to the Windows Systems Application Event Log. 

 Note:  This screen and steps are provided for illustration purposes only.  Function Statistic activity is 
performed by DCC Technical Services and the development team to troubleshoot problems and answer 
system related questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Alerts Tab: 
 1. Click to select the Alerts tab to bring this screen to the front. 

Fire alerts when The Fire alerts when option allows you to define the situations when you want alert messages sent. 
They include: No dial tone is detected, A line goes out of service temporarily, A line goes out of service 
permanently or A line goes back into service.  Alerts are sent to the Windows Systems Application 
Event Log. 

 2. At No dial tone is detected, click the check box to select  or click again to deselect .   

 3. At A line goes out of service temporarily, click the check box to select  or click again to deselect .  

 4. At A line goes out of service permanently, click the check box to select  or click again to deselect 
.   

 5. At A line goes back into service, click the check box to select  or click again to deselect .   

 6. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 
accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 28:  Click the 
Alerts tab to bring this 
screen to the front.   Make 
desired selections on the 
Alerts screen, and then 
click OK to save your 
changes and close the 
window.  
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The No Dial Tone Tab The No Dial Tone tab allows you to define how to handle situations when a dial tone is not 

found when placing a call. 
 

 Steps to Customize Options on the No Dial Tone Tab: 
 1. Click to select the No Dial Tones tab to bring this screen to the front. 

 2. At Each time delay the line for, click the text box and type the number of seconds. 

 3. At When no dial tone is detected, click the text box and type the number of times in a row.  Then 
choose one of the following radio buttons: 

 Click to select the Do nothing radio button. 
 Click to select Take the line out of service for radio button and type the number of seconds. 
 Click to select Take the line out of service permanently radio buttons. 

 4. Click OK to accept the selected options and return to the Pager Monitor window.  Click Apply to 
accept the selected options and leave the Pager Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 29:  Click the No 
Dial Tone tab to bring this 
screen to the front.   Make 
desired selections on the 
No Dial Tone screen, and 
then click OK to save your 
changes and close the 
window.  
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Function Statistics Function Statistic is used by DCC Technical Services and the development team to troubleshoot 

problems. Data is available if the Function Statistics options were selected on the Debug tab in 
the Pager Options window. 

 Note:  This screen and steps are provided for illustration purposes only.  Function Statistic activity is 
performed by DCC Technical Services and the development team to troubleshoot problems and answer 
system related questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to View Function Statistics: 

 1. At the Pager Monitor window, click Tools > Function Statistics.  The Function Statistics window 
displays. 

 2. You can do any one of the following as desired:  
 Click Clear to remove the items in the function list.  
 Click OK to close the Function Statistics window. 

 
Figure 30:  Click Tools > 
Function Statistics to 
access the Function 
Statistics window.  Click 
OK to return to the Pager 
Monitor screen.  
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Close on Detach 

Using the Tools > Close on Detach options gives you the ability to detach the Pager Monitor 
from the Pager Net Service. By default, the Pager Monitor will close when the Pager Net 
Service is unavailable or is Shutdown. 
 

 

 

Steps to Close on Detach: 

 1. Click Tools > Close on Detach.  The check mark is removed (the option disabled). Repeat this 
process to enable this setting. 

   
Using the Tools > Machine options gives you the ability to access a different machine or server 
to monitor the activity taking place. 
 

Access a Different 
Machine 

 
Steps to Access a Different Machine: 

 1. Click Tools > Machine.  The Connect to machine window will display. 

 2. At Machine Name, click the text box to select and type the name of the machine or server. 

 3. Click OK to connect to the defined machine (a message will display stating ‘Attaching to Service…’) 
or click Cancel to abort the action. 

 
Figure 31:  To access a 
different machine to 
monitor Pager activity, 
click Tools > Machine.  
The Enter the name of 
machine to monitor 
window displays.  At 
Machine Name, click the 
text box to select and type 
the name of the machine or 
server.  Click OK to 
connect to the defined 
machine.  
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If you right click anywhere in the bottom display area, a menu will display allowing you to Clear 
or Suspend/Resume Logging (this option will act as a toggle between the 2 options).  Suspend 
Logging will pause the Pager Monitor from posting activity to the display area. 
 

Suspend/Resume 
Logging 

 

Steps to Suspend/Resume Logging: 

 1. Right click anywhere in the bottom display area.  A menu will display. 
2. Click Suspend Logging.  The Pager Monitor will stop posting activity to the display area. 

 3. Right click anywhere in the display area.  A menu will display.  

 4. Click Resume Logging.  The Pager Monitor will restart posting activity to the display area.  
 

Figure 32:  Right 
anywhere in the bottom 
display area to display a 
menu. The Suspend / 
Resume Logging option 
will act as a toggle 
depending on the current 
state of the display area.  
Click Suspend/Resume 
Logging to activate that 
option.  
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If you right click anywhere in the bottom display area, a menu will display allowing you to 
Clear or Suspend/Resume logging from the main screen.  The Clear option will clear all 
message from the bottom display area. 
 

Clear the Display 
Area 

 

Steps to Clear the Display Area: 
 1. Right click anywhere in the display area.  A menu will display. 
 2. Click Clear.  The Pager Monitor display area will clear all messages.  

 Note:  To view the messages again after they have been cleared, click Tools > machine name (add 
listed at the bottom of the Tools menu). 

 
    

Exit the Pager Monitor Application 
To close the Pager Monitor application select Exit from the File menu or select the close icon 
located on the upper right of the title bar. 
 
Steps to Exit the Pager Monitor Application: 

 

1. At the Pager Monitor screen, click the File menu, and then click Exit (or click  on the upper 
right of the title bar). 

 
Figure 33:  To exit the 
Pager Monitor 
application, click the close 
button on the upper right of 
the title bar or select File > 
Exit.  
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Phone Monitor 
     

 
What Is Phone Monitor? 

 The Phone Monitor application is a component of RxT.  Both the Frontwave IVR™ system 
and the Communicator! NXT system can use this application to monitor phone 
communications and monitor phone line status.  It also allows the user to configure setting related 
to call routing, information logging, etc. 

Frontwave can use this application to view the phone log for messages sent for certain situations 
(e.g., outage notifications via the Outage Processor application, etc.).  Communicator! NXT 
can view the phone notification log for phone messages sent to contacts included in an 
activation.  Although this application monitors the phone activity it is not the service that 
physically sends phone messages.  The phone messages are sent via the Voice Net Service that 
runs in the background of RxT.  The Phone Monitor is, however, capable of initiating and 
shutting down the phone service. 

Typically, the Phone Monitor application will be used to view the activity of voice lines and 
troubleshoot problems.   
Phone Monitor application allows you to: 

 Customize Phone Options 
 Enable/Disable phone lines and stop active calls 
 Debug phone lines 
 Modify settings for a phone line 
 Get function statistics and/or process these statistics 
 Connect to different machines or servers to monitor activity 
 Suspend/Resume logging activity within the application 
 Clear the display window 
 Shutdown the Phone Service to terminate all phone activity 
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How Do I Access the Phone Monitor Application? 

 
 

The Phone Monitor is used to monitor phone communications for both Frontwave and 
Communicator! NXT. Access the Phone Monitor application to monitor phone 
communications, observe phone line status and configure setting related to phone lines. 

 

 Steps to Access the Phone Monitor Application: 
1. Double click the DCC Menu icon on the Desktop. The Login screen displays. 
2. At User Name, type the name, and then press Tab.  
3. At Password, type the password, and then click OK.  The DCC Menu displays. 
4. Click RxT Client Monitors located in the left hand pane.  The window on the right will display a 

variety of icons. 
5. Click the Phone Monitor icon located in the right hand pane.  The Voice Net Monitor screen 

displays. 

 

 

 

 

 

 

 

 

Figure 34:  Select the DCC Menu 
Icon on the Desktop.  The Login 
dialog box displays.  Type your User 
Name and Password and click OK.  
The DCC Menu displays. Click RxT 
Client Monitors located in the left 
hand pane, and then click the Phone 
Monitor icon located in the right hand 
pane. The application opens and the 
Voice Net Monitor window displays. 
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About the Work Area 

 When the Phone Monitor application is launched a variety of screen components display.  The 
applications window will display a: 

 Title bar – displaying the name of the application,  Voice Net Monitor – xxx (where xxx is the 
name of the machine or server configured to monitor phone activity). 

 Menu bar – these menu options provide an easy way of accessing functions available in the Phone 
Monitor application. 

 Device window – shows the current status of each phone line and how many lines are available in the 
system. 

 Logging window – displays information concerning the phone client, such as, phone transactions and 
error messages captured from system activity. 

 Status bar – displays statistical information about the phone lines. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 35:  The Voice Net Monitor application window is composed of 4 sections – the Menu Bar provides access to options to help manage and work 
with the phone monitor – the top pane or Device Window shows the current status of each phone line and how many lines are available in the system – 
the bottom pane or Logging Window displays information concerning the phone client such as error messages captured from system activity and phone 
transactions –  the Status Bar displays statistical information about the phone lines in use.   

 

       
Resize Columns The columns can be resized in the Phone Monitor application:  

 To Resize point to a vertical column line between column titles. The cursor will change to display .  
Press, hold and drag the column line to desired size. 

 Note:  Use the scroll bar located at the bottom of the screen to view all available information. 

Title Bar 

Menu Bar 

Status Bar 

The top pane or
Device window
displays information
about the configured
device. 

The bottom pane or
Logging window
displays information
concerning the
activity being logged
for a selected
device. 
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The Menu Bar 
 

The menu bar is located at the top of the Voice Net Monitor main window. The following 
menu options are displayed on the menu bar: 

File Menu The File menu provides the ability to exit, stop active calls, disable or enable lines or shutdown 
the Phone Monitor application. 

Edit Menu The Edit menu provides the ability to edit a selected line by accessing the Modify Settings for 
Line window. 

Tools Menu The Tools menu provides the ability to set phone options, switch to a different server or machine 
to monitor, view or process function statistics. 

 Help Menu The Help menu allows you to view information about Phone Monitor. 
 

Figure 36: The Voice Net 
Monitor main window 
displays available menu 
options.  The menu bar 
options provide a way of 
accessing functions.  Select 
the desired menu to display 
options that relate to the 
chosen menu. 
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The Display Area 
 

The Device Window, located in the top pane, shows the current status of each phone line and a 
listing of each line available in the system. The display area shows columns of information that 
include: 
Device  Will display as an icon representing voice line activity along with the line 

number assigned.  The line number indicates the physical line used for the 
call.  

Owner  The callflow name that is currently active.  
State The state of the phone line (e.g., Idle, Active, etc.). 
Status  The status of the device and activity messages identifying what is occurring 

on the device line (e.g., Ready and waiting for calls, Waiting, Sending, 
Delaying, Active, Closed, Out of service, etc.). 

Voice  An indicator will display showing if a voice device is enabled. The area will 
be blank if the device has not been configured.  

Fax  An indicator will display showing if a fax device is enabled. The area will be 
blank if the device has not been configured.  

ASR Automatic Speech Recognition will display an indicator if it is enabled. The 
area will be blank if the device has not been configured. 

Monitor  An indicator will display if monitoring is enabled. Enabling the monitor 
allows you to record each call (tones and conversation) to a .vox file. The 
area will be blank if the device has not been configured. 

DTMF  Dual Tone Multi Frequency (telephone keypad digits).  Will display the 
digits the caller has pressed while in the identified callflow.  

ANI  Automatic Number Identifier or the phone number of the inbound call (the 
phone number the customer is calling from).  

DNIS  Dialed Number Identification Service or the trunk number sent by the phone 
switch (the phone number the customer is calling).  

 Note:  If you right click anywhere in the top pane or bottom pane, a quick actions menu will display.  

 

 
Logging Pane The Logging Window, located in the bottom pane, displays information concerning the phone 

client such as error messages captured from system activity and phone transactions. 
Date  The date of the listed activity.  
Time  The time of the listed activity.  
Device The line number corresponding to this log message. 
Type  the type of message being logged (e.g., Information, Error, Warning, Debug, 

etc.) 
Source  The identifier that points to the source code that allows the DCC developers 

to troubleshoot any problems.  
Message  Describes the activity occurring.  

 Note:  If you right click anywhere in the Logging window or bottom pane, a menu will display with 
various options. 
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Status Bar The Status Bar, located at the bottom of the window, displays statistical information about the 

phone lines in use. 
Connected The machine name currently being monitored. 
Active The number of active lines out of the total number of lines. 
Busiest The number of concurrently active lines. 
Inbound Identifies how many lines have been designated for inbound calls. 
Outbound Identifies how many lines have been designated for outbound calls. 
Disabled Identifies how many lines have been disabled. 
Shutdown Identifies how many lines have been shutdown. 

Fax Identifies the number of lines designated for fax calls. 

Monitor The number of monitored lines out of the total number of lines. 

 
Figure 37:  The Voice Net 
Monitor main window 
displays a status bar located at 
the bottom of the screen.  The 
status bar displays statistical 
information about the phone 
lines in use. 
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Working with the Phone Monitor 

 

The Phone Monitor application can be used to stop active calls, enable or disable lines, 
shutdown the Voice Net service, configure line settings, customize phone options, view function 
statistics, suspend/resume logging, and switch to different server to view activity, etc.  An 
example of phone activity might be: 

 Phone messages sent to contacts during a scenario activation by Communicator! NXT. 
 Messages sent for certain situations (e.g., outage notifications via the Outage Processor 

application, a caller has accessed the Account Balance Inquiry line, etc.) by the 
Frontwave system. 
 

Stop Active Calls Stop Active Calls will terminate all active calls and stop all current calls and hang-up the phone 
lines for all listed devices. 
 

 Steps to Stop Active Calls: 

 1. At the Voice Net Monitor window, click File > Stop active calls or right click in the top pane to 
display a menu and click Stop active call.  The Voice Net Monitor window will display with a 
Warning message. 

 2. At the Warning message, click Yes to stop placing phone calls or click No to cancel the action. 
 

Figure 38:  To stop all 
active calls, click File > 
Stop Active Calls.  At the 
Warning message, click 
Yes to stop calls or click No 
to cancel the action.  
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Disable/Enable 
Lines 

Disable lines will prevent the listed phone lines from making new calls.  An indicator will display 
next to the device icon to represent the lines are down.  Enable the line will reactivate the 
connection so new phone calls can be made. 
 

 Steps to Disable Lines: 
1. At the Voice Net Monitor window, click File > Disable Lines.  The Voice Net Monitor window will 

display with a Warning message. 
2. At the Warning message, click Yes to disable all the listed phone lines or click No to cancel the action.

 

 Steps to Enable Lines: 
1. At the Voice Net Monitor window, click File > Enable Lines.   
2. At the Warning message, click Yes to enable all the listed phone lines or click No to cancel the action. 

The phone lines will be activated. 
 

Figure 39:  To disable the 
phone lines, click File > 
Disable Lines.  At the 
Warning message, click 
Yes to disable the phone 
lines or click No to cancel 
the action.  Disable lines 
will prevent all the listed 
phone lines from making 
new calls. 

To enable the disabled 
phone lines, click File > 
Enable Lines.  The phone 
lines will be activated. 

 

 

 



 
SYSTEM ADMINISTRATION: PHONE MONITOR 

 --5511-- Doc 4.x 

       
Shutdown the 
Phone Service 

The Shutdown option will terminate the Voice Net Service.  The system will respond by 
changing the status to close and exit the Phone Monitor application.  Voice calls will not be sent 
or received if the Voice Net Server is down. 
To restart the Phone Monitor after it has been shutdown, open the application by selecting DCC 
Menu > Client Monitors > Phone Monitor.  The phone lines will re-initialize or restart. 
 

 Steps to Shutdown the Phone Service: 
1. At the Voice Net Monitor window, click File > Shutdown.  The Voice Net Monitor window will 

display with a Warning message. 
2. At the Warning message, click Yes to shutdown the Voice Net Server and voice engine or click No to 

cancel the action. The voice engine will shutdown and the Phone Monitor application will close. 
 

Figure 40:  To shutdown 
the Voice Net Service, 
click File > Shutdown.  At 
the Warning message, click 
Yes to shutdown the Voice 
Net Server or click No to 
cancel the action.  Voice 
calls will not be sent or 
received if the Voice 
engine is down. 
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Debug a Line The Debug a line option can be accessed by right clicking in the Device window (top pane). 

When this option is selected, FSL debugging is enabled on the selected line. An active call will be 
paused and the FSL debugging activity will be displayed in the Logging window.  

 

 Steps to Debug a Line: 
1. At the Device window, right click to display a menu, and then click Debug. A Warning message 

displays. 
2. At the Warning message, click Yes to begin FSL debugging or click No to cancel the action. An active 

call will be paused and the FSL debugging activity will be displayed in the Logging window. 
 

Figure 41:  To Debug a 
line, right click to display a 
menu, and then click 
Debug.  At the Warning 
message, click Yes.  
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Dump Activity The Dump Activity option can be accessed by right clicking in the Device window (top pane). 

This option will take a snapshot of the current state of the selected line and send it to the 
VoiceNetService log and the Logging window (bottom pane).  

 

 Steps to Dump Activity: 
1. At the Device window, right click to display a menu, and then click Dump Activity. The Logging 

window will be updated with the information sent to the VoiceNetService log.  If necessary, use the 
scroll bar to view additional information. 

 
Figure 42:  At the Device 
window, right click to 
display a menu, and then 
click Dump Activity. The 
Logging window will be 
updated with the 
information sent to the 
VoiceNetService log. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
      

Restart Line The Restart Line option can be accessed by right clicking in the Device window (top pane). This 
option will restart a line that has been stopped. 

 

 Steps to Restart a Line: 
1. At the Device window, right click to display a menu, and then click Restart line.  
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Edit a Line Steps to Edit a Line: 

1. Click to select the desired device in the Device window (top pane). 
2. Click Edit > Line or right click in the top pane to display a menu and click Edit.  The Modify Settings 

for line: xxx window will display, where xxx is the number of the selected line. 

Line, Description The Line number will identify the selected line number and the Description will define information 
about the modem, card type, etc. 

 3. At Call flow, click  and click to select the desired callflow. 

Call Flow The Call flow dropdown list will list callflows that have been submitted as Inbound via the Call Flow 
Builder application.  The selected callflow will be assigned to the selected line (available call flows will 
differ from site to site). 

 4. At DTMF Voice, click the check box corresponding to Inbound and/or Outbound. 

DTMF Voice When enabled, DTMF Voice will display the digits the caller has pressed, in the Voice column at the 
Device window, while in the identified callflow for Inbound and/or Outbound calls.   

 5. At Fax documents, click the check box corresponding to Inbound and/or Outbound. 

Fax documents If fax is enabled for the line, then the Fax documents fields will be active and selectable.  If Inbound is 
selected then an indicator will display representing Inbound faxes in the Fax column.  If Outbound is 
selected then an indicator will display representing Outbound faxes in the Fax column. 

 6. At Speech Recognition, click the check box corresponding to Inbound and/or Outbound. 

Speech Recognition If speech recognition is enabled for the line, the Speech Recognition will fields will be active and 
selectable.  If Inbound is selected, an indicator will display representing Inbound speech recognition in 
the ASR column displayed at the Device window.  If Outbound is selected, an indicator will display 
representing Outbound speech recognition is enabled. 

 7. At Monitor, click the check box corresponding to Enable. 

Monitor Enabling the Monitor allows you to record each call (tones and conversation) to a .vox file (located at 
…\DCC\Program\Phone\Monitor with a file named M [line number] [yymmdd] [hhmmss]) until the 
option is disabled (remember to turn this option off when diagnosis is complete). When enabled, OK 
will display. When recording, Rec will display. Please be advised that for each line monitored, you must 
have a corresponding disabled line to do the monitoring. 

B2B Consult B2B Consult is used in Two B Channel Transfer. When an incoming line asks for a transfer, the system 
will use this line for an outgoing call to locate the requested extension. The two B channel lines are then 
tied together and passed to the telephone company, freeing up two lines on the system. 

 8. At Extension, click the text box and type the extension number if desired. 

Extension The Extension is passed to the CTI (Computer Telephony Interface). 

 9. At DNIS, click the text box and type the DNIS number. 

DNIS The DNIS, (Dialed Number Identification Service) is the phone number the customer is calling.  It 
assigns a DNIS to the selected line and can be used for CTI. 

10. At Transfer ID, click the text box and type the transfer ID. 

Transfer ID The Transfer ID allows you to assign a category to the call.  The Transfer ID is created in the Transfer 
Records application for the Transfer Type of Supervised or Unsupervised with an Extension Type of 
Transfer ID and an Extension Group created. The Transfer ID refers to the value entered in the Key 
field assigned to a Group Member.  Refer to the user guide titled Transfer Records and the topic titled 
Create an Extension Group for more information. 

 continued… 
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 11. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Cancel to 

close the window without saving any changes. 

 Note:  This activity is done during systems installation.  If changes need to be made or if you have any 
questions, please contact DCC Technical Services for assistance. 

 
Figure 43:  To modify 
line settings, click Edit > 
Line.  Make desired 
selections, and then click 
OK to accept the 
selected options and 
return to the Voice Net 
Monitor window. 
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Customize Phone 
Options 

Select Options from the Tools menu to access the Phone Options screen.  The Phone Options 
screen displays a variety of Tabs that organize related options into a logical display.  Select the 
desired tab heading to bring that screen to the front. 

 
Steps to Access Phone Options: Access Phone 

Options 1. At the Voice Net Monitor window, click Tools > Options.  The Phone Options window displays
defaulting to the Call Routing tab. 

 
Figure 44:  To access the 
Phone Options screen, 
click Tools > Options.  The 
Phone Options window 
displays. The Call Routing 
tab displays as a default.   
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The Call Routing Tab The Call Routing tab allows you determine how to handle inbound calls, perform ANI routing 

maintenance, perform DNIS routing maintenance and select what action to take if routing fails. 
 

 Steps to Customize Options on the Call Routing Tab: 

 1. Click to select the Call Routing tab to bring this screen to the front, if necessary. 
2. At Handle inbound calls in the following manner, click the radio button that corresponds to one of 

the following: 

  Always use the following call flow – Click  and select the desired callflow.  The Call flow 
dropdown list will display all call flows that have been submitted as Inbound via Call Flow 
Builder.  The selected callflow will be assigned to the selected line. 

 Use the call flow associated with the phone line – refer to topic titled Edit a Line. 
 Look up the call flow using the collected ANI – use the ANI Records button to customize these 

options. Refer to the following steps for further information. 
 Look up the call flow using the collected DNIS  –  use the DNIS Records button to customize 

these options. Refer to the following steps for further information. 
 Get the routing information from the CTI interface – the CTI (Computer Telephony Interface) 

instructs the system which script to run. 
 continued… 
 

Figure 45:  Make desired 
selections on the Call 
Routing screen, and then 
click OK to save your 
changes and close the 
window. 
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 3. To access the ANI Routing information screen, click the ANI Records button.  The ANI Routing 

Information screen displays.  The following actions can be preformed with ANI records:  

ANI Records The ANI Records button will access the ANI Routing Information screen where new ANI 
information can be added and a call flow and/or transfer record associated with the ANI record – used  
by the system to determine which callflow to run based on the phone number (e.g., if live in one 
location a specific script will run versus a script designated for a different location).  ANI records can be 
added, edited, deleted, imported or exported. 
ANI is the phone number the customer is calling from.  

 Add New ANI Information: 
 At the ANI Routing Information screen, click Add.  The New ANI information window 

displays. 
 At ANI, click to select the text box and type the ANI number. 
 At Callflow, click  and click to select the desired callflow.   
 At Transfer ID, click to select the text box and type the transfer ID. 

 At Do Secondary DNIS Routing, click the check box to select  or click again to deselect . 
 Click OK to save the changes and return to the ANI Routing Information window or click 

Cancel to abort the action. 
 At the ANI Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 Edit ANI Information: 
 At the ANI Routing Information screen, double click the desired ANI record.  The Edit ANI 

information window displays. 
 At Callflow, click  and click to select the desired callflow.   
 At Transfer ID, click to select the text box and type the transfer ID. 

 At Do Secondary DNIS Routing, click the check box to select  or click again to deselect . 
 Click OK to save the changes and return to the ANI Routing Information window or click 

Cancel to abort the action. 
 At the ANI Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 Delete ANI Information 
 At the ANI Routing Information screen, click to select one or more ANI records.   
 Click Delete.  The selected ANI records are removed from the system. 
 At the ANI Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 continued… 
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 Import ANI Information 
 At the ANI Routing Information screen, click Import.  The Import ANI records dialog box 

displays. 
 Click  to open the Select a file for importing window, and then choose the desired drive and 

folder at the Look in field. 
 Click to select the desired .txt file, and then click Open.  If the selected file contains a header 

record, click the First row contains header check box. 
 Click Import. An Import completed message will display with the results of the import. Click 

OK. The imported ANI records will display in the listing. 
 At the ANI Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 Export ANI Information 
 At the ANI Routing Information screen, click to select one or more ANI records, and then click 

Export. The Export ANI records dialog box displays. 
 Click  to open the Select a file for exporting window, and then choose the desired drive and 

folder at the Look in field. 
 At File name, click to select the text box, type a file name, and then click Open.  The file will be 

saved as a *.csv (comma delimited) file type. If the selected file contains a header record, click the 
First row contains header check box. 

 Click Export.  An Export completed message will display with the results of the export. Click 
OK. The exported ANI records will be saved to a file. 

 At the ANI Routing Information screen, click OK to save the changes and return to the Call 
Routing screen or click Cancel to abort the action. 

 continued… 

 
Figure 46:  To access the 
ANI Routing Information 
screen, click the ANI 
Records button on the Call 
Routing screen.  The ANI 
Routing Information 
screen provides the options 
to Add, Delete, Import, 
Export or Edit ANI 
records.  Make desired 
selections, and then click 
OK to save your changes 
and close the window. 
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 4. To access the DNIS Routing Information screen, click the DNIS Records button.  The DNIS Routing 

Information screen displays.  The following actions can be preformed with DNIS records:  

DNIS Records The DNIS Records button will access the DNIS Routing Information screen where new DNIS 
information can be added and a call flow and/or transfer record associated with the DNIS record – used  
by the system to determine which callflow to run based on the phone number (e.g., if live in one location 
a specific script will run versus a script designated for a different location).  DNIS records can be added, 
edited, deleted, imported or exported. 
DNIS is the phone number the customer is calling. 

 Add New DNIS Information: 
 At the DNIS Routing Information screen, click Add.  The New DNIS information window 

displays. 
 At DNIS, click to select the text box and type the DNIS number. 
 At Callflow, click  and click to select the desired callflow.   
 At Transfer ID, click to select the text box and type the transfer ID. 

 At Do Secondary ANI Routing, click the check box to select  or click again to deselect . 
 Click OK to save the changes and return to the DNIS Routing Information window or click 

Cancel to abort the action. 
 At the DNIS Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 Edit DNIS Information: 
 At the DNIS Routing Information screen, double click the desired DNIS record.  The Edit DNIS 

information window displays. 
 At Callflow, click  and click to select the desired callflow.   
 At Transfer ID, click to select the text box and type the transfer ID. 

 At Do Secondary ANI Routing, click the check box to select  or click again to deselect . 
 Click OK to save the changes and return to the DNIS Routing Information window or click 

Cancel to abort the action. 
 At the DNIS Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 Delete DNIS Information: 
 At the DNIS Routing Information screen, click to select one or more DNIS records.   
 Click Delete.  The selected DNIS records are removed from the system. 
 At the DNIS Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 continued… 
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 Import DNIS Information: 
 At the DNIS Routing Information screen, click Import.  The Import DNIS records dialog box 

displays. 
 Click  to open the Select a file for importing window, and then choose the desired drive and 

folder at the Look in field. 
 Click to select the desired .txt file, and then click Open.  If the selected file contains a header 

record, click the First row contains header check box. 
 Click Import. An Import completed message will display with the results of the import. Click 

OK. The imported DNIS records will display in the listing. 
 At the DNIS Routing Information screen, click OK to save the changes and return to the Call 

Routing screen or click Cancel to abort the action. 

 Export DNIS Information: 
 At the DNIS Routing Information screen, click to select one or more DNIS records, and then 

click Export. The Export DNIS records dialog box displays. 
 Click  to open the Select a file for exporting window, and then choose the desired drive and 

folder at the Look in field. 
 At File name, click to select the text box, type a file name, and then click Open.  The file will be 

saved as a *.csv (comma delimited) file type. If the selected file contains a header record, click the 
First row contains header check box. 

 Click Export.  An Export completed message will display with the results of the export. Click 
OK. The exported DNIS records will be saved to a file. 

 At the DNIS Routing Information screen, click OK to save the changes and return to the Call 
Routing screen or click Cancel to abort the action. 

 continued… 

 
Figure 47:  To access the 
DNIS Routing 
Information screen, click 
the DNIS Records button 
on the Call Routing screen.  
The DNIS Routing 
Information screen 
provides the options to Add, 
Delete, Import, Export or 
Edit DNIS records.  Make 
desired selections, and then 
click OK to save your 
changes and close the 
window. 
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 5. At If the Routing fails, click the radio button that corresponds to one of the following: :  

 6. Use the following call flow - Click  and click to select the desired callflow.  The Call flow dropdown 
list will list all callflows that have been submitted as Inbound via Call Flow Builder.  The selected 
callflow will be assigned to the selected line in the event routing fails. 

7. Transfer the call – Click  and click to select the desired transfer record.  The transfer record
dropdown list will list all transfer records that exist in the Transfer Records application.  The selected 
transfer record will be assigned to the selected line in the event routing fails. 

 8. At Phone Options > Call Routing, click OK to accept the changes and return to the Voice Net 
Monitor screen.  Click Apply to save the changes and leave the Phone Options screen open.  Click 
Cancel to about the changes and return to the Voice Net Monitor screen.  

 
Figure 48:  When 
selections have been 
complete on the Call 
Routing screen, click OK 
to accept the changes and 
return to the Voice Net 
Monitor screen.  Click 
Apply to save the changes 
and leave the Phone 
Options screen open.  Click 
Cancel to about the changes 
and return to the Voice Net 
Monitor screen. 
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The ANI/DNIS Tab The ANI/DNIS tab allows you to determine if you will collect ANI / DNIS information and if so, 

allows you to select a source from which to collect this information (e.g., from the hardware or 
CTI interface, etc.). 
DNIS is the phone number the customer is calling – ANI is the phone number the customer is 
calling from. 

 Note:  This activity is done during systems installation and should not be changed.  If you have any 
questions, please contact DCC Technical Services for assistance. 

 
 Steps to Customize Options on the ANI / DNIS Tab: 

 1. Click to select the ANI/DNIS tab to bring this screen to the front. 

 2. At Collect ANI/DNIS from the following source, select one of the following by clicking the 
corresponding radio button: 

  Do not collect ANI/DNIS – information will not be collected if this option is enabled. 
 Use hardware (Caller ID, T1, ISDN, etc). 
 Use the selected CTI interface. 
 Use this Inbound Signaling script - Click  and click to select the desired script. 
 Use the ANI and DNIS assigned to the phone line. 

 3. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes. 

 
Figure 49:  Click the 
ANI/DNIS tab to bring 
this screen to the front. 
Make desired selections 
on the ANI/DNIS 
screen, and then click 
OK to save your 
changes and close the 
window returning to the 
Voice Net Monitor 
window. 
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The CTI Tab The CTI (Computer Telephony Interface) tab allows the appropriate CTI machine name to be 

defined – the machine where CTI is installed at the customer site.  This CTI information allows 
the system to interface directly with the telephone switch (PBX) in order to send and receive call 
routing information and collect information for reports.  

 Note:  This activity is done during systems installation and should not be changed.  If you have any 
questions, please contact DCC Technical Services for assistance. 

 
 Steps to Customize Options on the CTI Tab: 

 1. Click to select the CTI tab to bring this screen to the front. 

 2. At CTI Machine, type the machine name at the text box. A blank entry means that CTI is not installed. 

 3. At Collect CTI Unique Call ID, click the check box to select  information to be collect for reports. 

 4. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes. 

 
Figure 50:  Click the 
CTI tab to bring this 
screen to the front. 
Make desired selections 
on the CTI screen, and 
then click OK to save 
your changes and close 
the window returning to 
the Voice Net Monitor 
window. 
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The FSL Tab The FSL, or Flying Scripting Language (an interpreted language), tab is used by DCC Technical 

Services and the development team for troubleshooting system problems.  This screen provides 
options to - Allow FSL debugging, Force breakpoint on start, Force breakpoint on errors, 
Breakpoints, Debug Lines and FSL Timeouts. 

 Note:  This screen and steps are provided for illustration purposes only.  FSL activity is preformed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to View Options on the FSL Tab: 
 1. Click to select the FSL tab to bring this screen to the front. 

 2. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply 
to accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 51:  Click the FSL 
tab to bring this screen to 
the front. Make desired 
selections on the FSL 
screen, and then click OK 
to save your changes and 
close the window. 
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The Test Numbers 

Tab 
The Test Numbers tab allows test numbers to be set up for the system to call versus live callouts.  
These options are used to force the system to call numbers from the test number list whenever it 
makes outbound calls (e.g., a new device was added and needs to be tested, etc.). 

 Note:  This screen and steps are provided for illustration purposes only.  Test Number activity is 
preformed by DCC Technical Services and the development team to troubleshoot problems and answer 
system related questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Test Numbers Tab: 
 1. Click to select the Test Numbers tab to bring this screen to the front. 

 2. At Test Number Option, click  and select Sequential or By line number. 

Test Number If Sequential, the system will use the line numbers in sequential order when assigning test numbers to 
be called. For example, if there are 2 lines and 3 test numbers, and line number 1 is assigned number 
1111, line number 2 is assigned number 2222, then line number 1 is assigned number 3333. 
If By line number, the system will assign 1 test number to each line. For example, if there are 2 lines 
and 3 test numbers, and line number 1 is assigned number 1111, line number 2 is assigned number 
2222, then number 3333 is not assigned and, therefore, never called. 

 3. Add Test Phone Numbers:  
 Click Add.  The cursor will display in the Test numbers pane. If numbers already exist, then the 

next sequential number will be copied to a new line and highlighted. 
 Type the desired phone number and press Enter.  The number has been added to the listing. 

 4. Delete Test Phone Numbers:  
 Click to select one or more test phone numbers listed in the Test numbers pane. 
 Click Delete, and then click Yes at the confirmation message.  The numbers are removed. 

 5. At Use test numbers, click the check box to select  or click again to deselect . 

Use Test Number Use test numbers indicates the system will call numbers from the test number list whenever it makes 
outbound calls.  This primarily used when someone needs to troubleshoot the system. 

 6. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 52:  Click the Test 
Number tab to bring this 
screen to the front. Make 
desired selections on the 
Test Numbers screen, and 
then click OK to save your 
changes and close the 
window. 
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The Fax Tab The Fax tab allows you to specify if received faxes and/or faxes per line are saved in 

subdirectories.  This function is used by DCC Technical Services and the development team for 
testing purposes. 

 Note:  This screen and steps are provided for illustration purposes only.  Debug activity is preformed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Fax Tab: 
 1. Click to select the Fax tab to bring this screen to the front. 

 2. At Save received faxes, click the check box to select  or click again to deselect . 

 3. At Save fax per line, click the check box to select  or click again to deselect .  

 4. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 53:  Click the Fax 
tab to bring this screen to 
the front. Make desired 
selections on the Fax 
screen, and then click OK 
to save your changes and 
close the window. 
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The Logging Tab The Logging tab allows you select where the activity information will be recorded.  You can 

select one or more options (e.g., to an event log, to a text file, etc.), in addition to, defining the 
buffer size. 

 
 Steps to Customize Options on the Logging Tab: 

 1. Click to select the Logging tab to bring this screen to the front, if necessary. 

 2. At Log output to event log, click the check box to select  or click again to deselect . 

Log output to the event 
log 

The Log output to event log enables any activity that occurs to be logged into the Windows Systems 
Application Event Log.  This log option is typically disabled. 

 3. At Log Output to file, click the check box to select  or click again to deselect . 

Log Output to file The Log Output to file enables any activity that occurs to be logged to a text file - if this option is selected 
at the File to log to text box type the path and file name or click the More button to access the Open
dialog box where a file location and name can be entered.  Then, at Log separate devices, click the check 
box to select  or click again to deselect .  This option will create a separate log file for each phone 
line/device. 

 4. At Log buffer size, click the textbox and type in the number representing the buffer size. 

Log buffer size The Log buffer size defines the size of the storage area to hold log messages. 

 5. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes. 

 
Figure 54:  Click the 
Logging tab to bring this 
screen to the front. Make 
desired selections on the 
Logging screen, and then 
click OK to save your 
changes and close the 
window. 
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The Debug Tab The Debug tab allows you to select the specific type of messages that will display when logging 

phone activity.  In addition, it allows you the option to collect Function Statistics. 

 Note:  This screen and steps are provided for illustration purposes only.  Debug activity is preformed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Debug Tab: 
 1. Click to select the Debug tab to bring this screen to the front. 

 2. At Enable Debugging Messages, click the check box to select  or click again to deselect .  When 
selected the types of messages options become active and selectable. 

Enable Debugging 
Messages 

The Enable debugging messages setting is used exclusively by DCC for troubleshooting problems. 
System Administrators should not utilize this feature unless instructed by Technical Services.  Debug 
messages can include information related to supporting the system, the communications layer, the 
transmission of messages, etc. 

 3. At Collect Function Statistics, click the check box to select  or click again to deselect .   

Collect Function 
Statistics 

4. The Collect Function Statistics is reserved for use by DCC Technical Services and the development 
team to troubleshoot problems and answer system related questions.   

 5. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 55:  Click the 
Debug tab to bring this 
screen to the front. Make 
desired selections on the 
Debug screen, and then 
click OK to save your 
changes and close the 
window. 
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The Alerts Tab The Alerts tab allows you to define in what situations you want to fire alerts.  Alerts are sent to 

the Windows Systems Application Event Log. 

 Note:  This screen and steps are provided for illustration purposes only.  Debug activity is preformed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 

 Steps to Customize Options on the Alerts Tab: 
 1. Click to select the Alerts tab to bring this screen to the front. 

Fire alerts when The Fire alerts when options include No dial tone is detected, A line goes out of service temporarily, A 
line goes out of service permanently or A line goes back into service. 

 2. At No dial tone is detected, click the check box to select  or click again to deselect .   

 3. At A line goes out of service temporarily, click the check box to select  or click again to deselect .  

 4. At A line goes out of service permanently, click the check box to select  or click again to deselect .  

 5. At A line goes back into service, click the check box to select  or click again to deselect .   

 6. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply to 
accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes. 

 
Figure 56:  Click the Alerts 
tab to bring this screen to the 
front. Make desired 
selections on the Alerts 
screen, and then click OK 
to save your changes and 
close the window. 
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The No Dial Tone Tab The No Dial Tone tab allows you to define how to handle situations when a dial tone is not 

found when placing a call. 
 

 Steps to Customize Options on the No Dial Tone Tab: 
 1. Click to select the No Dial Tones tab to bring this screen to the front. 

 2. At Each time delay the line for, click the text box and type the number of seconds. 

 3. At When no dial tone is detected, click the text box and type the number of times in a row.  Then chose 
one of the following radio buttons:  

 Click to select the Do nothing radio button. 
 Click to select Take the line out of service for radio button and type the number of seconds. 
 Click to select Take the line out of service permanently radio buttons. 

 4. Click OK to accept the selected options and return to the Voice Net Monitor window.  Click Apply
to accept the selected options and leave the Phone Options window open.  Click Cancel to close the 
window without saving any changes.  

 
Figure 57:  Click the No 
Dial Tone tab to bring this 
screen to the front. Make 
desired selections on the No 
Dial Tone screen, and then 
click OK to save your 
changes and close the 
window. 
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The Tones Tab The Tones tab allows you to set up a scripting event to occur when a custom tone is detected. 

This allows DCC to handle events like receiving a fax or detecting and starting a TDD 
(telecommunications for the deaf) session. Tones can be added, changed or deleted. 
 

Name Name displays name of the tone (FAX, DIALTONE…). 

Event Event is a scripting Event (FAX_TONE, TDD, …). This event will be raised in a script to inform the script 
the tone has been detected (ERROR_FAX_TONE, ERROR_TTD). The script can then catch the error and 
handle the situation (receive a fax, start a TDD session). 

Freq1 Freq1 is the first frequency of the tone to detect (450 = 450hz). Freq1 dev is the first frequency deviation 
(50 = plus or minus 50hz). So, 450+/-50 will detect a frequency from 400hz to 500hz. 

Freq2 Freq2 is the second frequency. This is used for detecting dual frequency tones. Freq2 dev is the second 
frequency deviation. 

On time On time means duration tone must be present to be detected [50 = 500ms (1/2 second)]. On Dev is the 
deviation for on time (5 = plus or minus 50ms. 50+/-5 = tone must be present from 450ms to 550ms to be 
detected). On time and On Dev can be in the form of On time: 50 On Dev -50.  This instructs the engine to 
listen for a continuous tone lasting 1000ms (1 second). When this form is used, the Off Time and Off Dev 
must be 0. 

Off time Off time means duration tone must be absent after being present [50 = 500ms (1/2 second)]. Off Dev is the 
deviation for off time. 

Repeats Repeats is the number of time the on/off cycle must repeat before the detected event is raised. 

Enable when call 
starts 

If yes, the tone is automatically enabled when the call is answered/called. 

 Note:  This screen and steps are provided for illustration purposes only.  Tone activity is preformed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 
Figure 58:  Click the Tones 
tab to bring this screen to the 
front. Make desired 
selections on the Tones 
screen, and then click OK 
to save your changes and 
close the window. 
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The Transfer Tab The Transfer tab allows DCC to set up how transfers occur in the system based on the switch 

requirements. Transfers can be added, changed or deleted. 
 

Code Code is the transfer code for this transfer record. This can be A, B, C, D, E or F. 

Blind Transfer Pattern Blind Transfer Pattern is the dialing format used to execute a blind transfer.  If an ‘x’ is in the string, it will 
be replaced with the destination extension.  If an ‘s’ is in the string, it is replaced with the switch ID. 

Announced transfer 
start 

Announced transfer start is the dialing format used to initiate an supervised or announced transfer. Special 
characters are ‘s’ and ‘x’. Announced transfer Abort is the dialing format used to re-connect to the caller 
when a transfer is aborted.  If the switch does not use a reconnect code, this field will be blank.  The ‘s’ and 
‘x’ are special characters. 

Announced transfer 
finish 

Announced transfer Finish is the dialing format used to complete the transfer.  Usually this field is left 
blank.  The ‘s’ and ‘x’ are special characters. 

Use tone transfer The Use tone transfer is used when the phone switch uses DTMF tones to do a transfer versus a hook/flash. 

 Note:  This screen and steps are provided for illustration purposes only.  Transfer activity is preformed by 
DCC Technical Services and the development team to troubleshoot problems and answer system related 
questions.  Please contact DCC Technical Services for assistance with this activity. 

 
Figure 59:  Click the 
Transfer tab to bring this 
screen to the front. Make 
desired selections on the 
Transfer screen, and then 
click OK to save your 
changes and close the 
window. 
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Function Statistics Function Statistic is used by DCC Technical Services and the development team to troubleshoot 

problems and tune the application. Data is available if the Collect Function Stats option was 
selected on the Debug tab in the Phone Options window. 

 Note:  This screen and steps are provided for illustration purposes only.  Function Statistics activity is 
preformed by DCC Technical Services and the development team to troubleshoot problems and answer 
system related questions.  Please contact DCC Technical Services for assistance with this activity. 

 
 Steps to View Function Statistics: 

 1. At the Voice Net Monitor window, click Tools > Function Statistics.  The Function Statistics
window displays. Use the scroll bar to view additional columns of information. 

 2. You can do any one of the following as desired:  
 Click Clear to remove the items in the Function list.  
 Click Close to exit the Function Statistics window. 

 
Figure 60:  Click Tools > 
Function Statistics to 
access the Function 
Statistics window.  You can 
Clear the contents of 
screen.  Click Close to 
return to the Voice Net 
Monitor screen. 
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Process Statistics Process Statistic is used by DCC Technical Services and the development team for tuning the 

application. It can assist in answering questions like “Where is all that CPU going to?” to find 
bottlenecks in configurations, etc. 

 Note:  This screen and steps are provided for illustration purposes only.  Process Statistics activity is 
preformed by DCC Technical Services and the development team to troubleshoot problems and answer 
system related questions.  Please contact DCC Technical Services for assistance with this activity. 

 
 Steps to View Process Statistics: 

 1. At the Voice Net Monitor window, click Tools > Process Statistics.  The Process Statistics window 
displays. Use the scroll bar to view additional columns of information. 

 2. Click Close to exit the Process Statistics window. 
 

Figure 61:  Click Tools > 
Process Statistics to access 
the Process Statistics 
window.  Click Close to 
return to the Voice Net 
Monitor screen. 
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Using the Tools > Close on Detach options gives you the ability to detach the Phone Monitor 
from the Voice Net Service. By default, the Phone Monitor will close when the Voice Net 
Service is unavailable or is Shutdown. With this option disabled, the Phone Monitor window 
will remain open even if the Voice Net Service is unavailable or is Shutdown. 
 

Close on Detach 
 

Steps to Close on Detach: 

 1. Click Tools > Close on Detach.  The check mark is removed (the option disabled). Repeat this 
process to enable this setting. 

   
Using the Tools > Machine options gives you the ability to access a different machine or server 
to monitor the phone activity taking place. 
 

Access a Different 
Machine 

 
Steps to Access a Different Machine: 

 1. Click Tools > Machine.  The Connect to machine window will display. 

 2. At Machine name, click the text box to select and type the name of the machine or server. 

 3. Click OK to connect to the defined machine (a message will display stating ‘Attaching to Service…’) 
or click Cancel to abort the action. 

 
Figure 62:  To access a 
different machine to 
monitor phone activity, 
click Tools > Machine.  
The Enter the name of 
machine to monitor 
window displays.  At 
Machine Name, click the 
text box to select, and then 
type the name of the 
machine or server.  Click 
OK to connect to the 
defined machine. 
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If you right click anywhere in the bottom display area a menu will display allowing you to Clear 
or Suspend/Resume Logging (this option will act as a toggle between the 2 options).  Suspend 
Logging will pause the Phone Monitor from posting activity to the display area. 
 

Suspend /Resume 
Logging 

 

Steps to Suspend/Resume Logging: 

 1. Right click anywhere in the bottom display area.  A menu will display. 
2. Click Suspend Logging.  The Voice Net Monitor will stop posting activity to the display area. 

 3. Right click anywhere in the display area.  A menu will display. 

 4. Click Resume Logging.  The Voice Net Monitor will restart posting activity to the display area. 
 

Figure 63:  Right 
anywhere in the bottom 
display area to display a 
menu.  The Suspend 
/Resume Logging option 
will act as a toggle 
depending on the current 
state of the display area.  
Click Suspend/Resume 
Logging to activate that 
option. 
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If you right click anywhere in the bottom display area a menu will display allowing you to Clear 
or Suspend/Resume logging from the main screen.  The Clear option will clear all message 
from the bottom display area. 
 

Clear the Display 
Area 

 

Steps to Clear the Display Area: 

 1. Right click anywhere in the display area.  A menu will display. 

 2. Click Clear.  The Voice Net Monitor display area will clear all messages.  

 Note:  To view the messages again after they have been cleared, click Tools > machine name (add 
listed at the bottom of the menu). 

 
Figure 64:  Right 
anywhere in the bottom 
display area to display a 
menu.  Click Clear.  All 
messages will be removed 
from the display area. 
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Exit the Phone Monitor Application 

To close the Phone Monitor application, select Exit from the File menu or select the close icon 
located on the upper right of the title bar. 
 
Steps to Exit the Phone Monitor Application: 

 

1. At the Voice Net Monitor screen, click the File menu then click Exit (or click  on the upper right 
of the title bar). 

 
Figure 65:  To exit 
Voice Net Monitor, 
click the close button on 
the upper right of the 
title bar or select File > 
Exit. 
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Line Configuration 
 
 

What Is Line Configuration? 

 The Line Configuration application is a component of RxT, DCC’s patented notification 
technology and is used to set the dialing rules and properties for outbound calling.  This 
application allows the user to modify phone line settings by configuring individual telephone 
line Groups and to define the format used when outbound numbers are dialed by customizing 
Dialing Rules.  A Do Not Call List is also available to allow users to exclude phone numbers 
that should not be called. 
Line Configuration works in conjunction with outbound calls made by Frontwave IVR™ 
and Communicator! NXT.  The Line Configuration application allows you to: 

 Configure default dialing formats for all outbound calls. 
 Define Advanced Dialing Rules for Lines or Groups with options to import and export. 
 Specify a Do Not Call List. 
 Customize Telephony Settings by indicating Dialing Rules, Modem settings and 

install/configure telephony providers. 
 

 
About Line Configuration 

 
 

When the Line Configuration application is launched, a window displays consisting of a title 
bar, menu bar, a toolbar, and a list of options.  The following pages will go into detail for each 
menu option and icon displayed on the toolbar.  A general overview for each of the several menu 
options or displayed icon will be followed by detailed Step-by-Step instructions.  The Step-by-
Step will include a definition for each Field Name and a description of the choices for each field, 
in addition to a screen example. 
The options displayed on the main Line Configuration screen, consist of default formats for 
International, Long Distance, Local, Extension, Add Extension and Unknown for outbound 
phone numbers, as well as the Valid Digits that can be used in phone numbers. 

 Note:  A phone line cannot be created or deleted in the Line Configuration application.  Refer to RxT 
Client Monitors > Phone Monitor for more information. 

 
Figure 66:  The options 
displayed on the main Line 
Configuration screen, 
consist of default formats 
for International, Long 
Distance, Local, Extension, 
Add Extension and 
Unknown for outbound 
phone numbers, as well as 
the Valid Digits that can be 
used in phone numbers.  
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How Do I Access the Line Configuration Application? 

 
The DCC Menu screen displays thumbnail options in the left hand pane for navigating 
through the system’s menu.  All applications relating to Utilities are located at the 
Utilities icon.  

  
 Steps to Access the Line Configuration Application: 
 1. Double click the DCC Menu icon on the Desktop. The Login screen displays. 
 2. At Machine, select or type the name of the machine you want to access. 
 3. At User Name, type the name, and then press Tab. 
 4. At Password, type the password, and then click OK.  The DCC Menu displays. 
 5. Click Utilities located in the left hand pane.  The window on the right will display a variety of icons. 
 6. Double click the Line Configuration icon located in the right hand pane.  The Line Configuration 

screen displays. 
 

 

 
 

 

 

 

 

 

 

 

Figure 67:  Select the DCC Menu 
Icon on the Desktop.  The Login 
dialog box displays.  Type your User 
Name and Password and click OK.  
The DCC Menu displays.  Click 
Utilities, and then click the Line 
Configuration icon to launch the 
application.   
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About the Work Area 
 When the Line Configuration application is launched, a window displays consisting of a title 

bar, menu bar, a toolbar and the display area.   
 

Figure 68:  The Line 
Configuration application 
contains various menu 
options and tools to help 
manage phone lines.  
Shortcuts for menu options 
are displayed as icons on the 
toolbar.  

 

 

 

 

 

 

 

 

 
    

Menu Bar  The Line Configuration menu bar consists of several menus.  When one of the menu options 
is selected by clicking the name with the mouse, a drop down menu will display that provides a 
listing of additional actions that can be performed.  For example, when you click the Help 
menu, a dropdown menu will appear with options relating to the Help menu.  To select an 
option, move down the list until that option is highlighted and click with the mouse.   

 
Figure 69:  The Menu Bar 
displays various commands 
that can be preformed in the 
Line Configuration 
application.  Select the 
desired menu to display 
additional options that relate 
to the chosen menu. 

 

Menu Bar 
Toolbar 

Advanced 
Dialing 
Options Do Not 

Call List 
Title Bar 
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Configure Default Dialing Formats 

 Default dialing formats for outbound lines are configured on the main Line Configuration 
screen. The options displayed include default formats for International, Long Distance, Local, 
Extension, Add Extension and Unknown for outbound phone numbers, as well as defining the 
Valid Digits that can be used in phone numbers. 

 Note:  This information is provided for informational purposes only. Line Configuration is preformed by 
DCC Technical Services. Please contact them at 615-794-2307 for assistance. 

 
The following list of special dial string characters can be used to perform specific functions: 
L Listen for local dial tone 

Dial String 
Characters 

I Listen for international dial tone 
 X Listen for the Extra dial tone 
 T Tone dialing 
 P Pulse dialing 
 M Multi-frequency dialing 
 , Delay for 2 seconds 
 x Replaced with the extension number 
 ~ Do not perform call analysis when completed 
 ? Do a call analysis now.  If connected when done, continue. 
 \ Hang up the phone 
 / Pick up the phone 
 W Wait for silence on the line 
 # Pound key 
 * Asterisk key 
 & Flash-hook 
 ABCD Extra DTMF or MF digits used by switches to communicate routing codes, etc. 
 
 Example: If you specified an international format as T,,,011[Country][City][Subscriber], this would be translated 

as: tone dialing, wait 6 seconds, dial 011 (AT&T international operator), and then dial the Country, City and 
Subscriber numbers. 
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 Steps to Configure Default Dialing Formats: 

 1. At International Format, type the default dialing format to be used for outbound calls (e.g., 
T,,,9,011[Country][City][Subscriber]). 

International 
Format 

International is the setting for international phone numbers dialed by the system. For example, you may 
need to dial a 9 to get an outside line, use a comma (,) to create a 2 second pause needed to connect the 
phone line with a dial tone, 011(AT&T) for an international operator, and then the country, city and 
subscriber numbers. 

 2. At Long Distance Format, type the default dialing format to be used for outbound calls (e.g., 
T,,,9,[Country][City][Subscriber]). 

Long Distance 
Format 

Long Distance is the setting for long distance phone numbers dialed by the system. For example, you 
may need to dial a 9 to get an outside line, use a comma (,) to create a 2 second pause needed to connect 
the phone line with a dial tone, and then the country, city and subscriber numbers. 

 3. At Local Format, type the default dialing format to be used for outbound calls (e.g., T9,[Subscriber]). 

Local Format Local is the setting for local phone numbers dialed by the system. For example, you may need to dial a 9 
to get an outside line, use a comma (,) to create a 2 second pause needed to connect the phone line with a 
dial tone, and then the subscriber number. 

 4. At Extension Format, type the default dialing format to be used for outbound calls (e.g., T,,[Extension]). 

Extension Format Extension is the setting for extension phone numbers dialed by the system. For example, you may need 
to dial just the extension number. 

 5. At Add Ext Format, type the default dialing format to be used for outbound calls (e.g., ?W[Extension]). 

Add Ext Format Add Ext is the setting for additional extension phone numbers dialed by the system. 

 6. At Unknown Format, type the default dialing format to be used for outbound calls (e.g., T,[Number]). 

Unknown Format Unknown is the setting for unknown phone number formats encountered by the system.  

 7. Valid Digits list valid digits and special dial string characters can be used to perform specific functions. 
Refer to the Special Dial String Characters listing. 

 8. Click Apply to save your changes and leave the Line Configuration window open, click OK to save 
your changes and close the application or click Cancel to close the window without saving any changes. 

 
Figure 70:  Default dialing 
formats for outbound calls 
are configured on the main 
Line Configuration screen. 
The options displayed 
include default formats for 
International, Long 
Distance, Local, Extension, 
Add Ext and Unknown for 
outbound phone numbers, as 
well as defining the Valid 
Digits that can be used in 
phone numbers.  
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Advanced Dialing 

 

The Line Configuration application sets the dialing rules and properties for all outbound lines.  
Advanced Dialing allows you to configure Rules for Lines or Groups with options to import 
and export.  Changing these options will override the current line configuration options. 

 Note:  This information is provided for informational purposes only. Line Configuration is preformed by 
DCC Technical Services. Please contact them at 615-794-2307 for assistance. 

 
Steps to Access Advanced Dialing Options: Access Advanced 

Dialing Options 
1. At the Line Configuration screen, click on the Options menu click Advanced Settings (or click  

on the toolbar).  The Advanced Dialing Rules window displays defaulting to the Lines tab. 
 
Figure 71:  Click Options 
> Advanced Settings or 
click the icon to access the 
Advanced Dialing Rules 
screen.   
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Lines Tab 
 The Lines tab displays a listing of the configured phone lines identifying the Device Type, the 

Machine name, Server name, the Line Number, the Description (name of the phone line) and a 
Group name (if one has been assigned to the line). 

The Lines tab is used to edit and delete phone lines. 

 Note:  This information is provided for informational purposes only. Line Configuration is preformed 
by DCC Technical Services. Please contact them at 615-794-2307 for assistance. 

 
Edit a Line Steps to Configure Line Options: 

 1. Click the Lines tab to bring this screen to the front, if necessary. 

 2. Click to select the desired line. 

 3. Click Edit.  The Line Information dialog box displays. 

Line Information The Line Information window displays the Device Type, Machine name, Server name, Line Number, 
Description (name of the phone line) and Group name. Only the Group associated with the phone line 
can be changed.  

 4. At Group, click  and select the desired group.   

 5. Click OK to save the changes and return to the Line tab.  Click Cancel to abort the action.   

 6. At the Advanced Dialing Rules screen, click OK to return to the Line Configuration window.   
 
Figure 72:  At the Lines 
tab, click to select the 
desired line, and then click 
Edit.  The Line 
Information window for 
the selected line displays.  If 
desired, change the Group, 
and then click OK to return 
to the Advanced Dialing 
Rules screen. 
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Delete Lines Steps to Delete Lines: 

 1. Click the Lines tab to bring this screen to the front. 

 2. Click to select the desired lines from the listing.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent 
items, Shift + Click to select a range of items or use a combination of the two methods. 

 3. Click Delete.  The Confirm delete dialog box displays. 

 4. Click Yes to delete the selected lines or No to cancel the action. 

 5. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration screen. 

 
Figure 73:  At the Lines tab 
located in the Advanced 
Dialing Rules window, 
click to select the lines to 
delete.  Click the Delete 
button.  The Confirm 
delete dialog box displays.  
At the ‘Do you really want 
to delete the x lines?’ 
message, click Yes to delete 
the selected lines. 
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Groups Tab 
 Groups provides a mechanism to define dialing instruction for lines used by different devices 

(e.g., fax, alpha pager, modem, T1, analog card, etc.). Once dialing instructions for a group has 
been defined, the group is associated to a line or dialing rule. 

The Groups tab is used to create, edit, delete, import or export phone line groups to be used in 
place of the default group settings. 

 Note:  This information is provided for informational purposes only. Line Configuration is preformed 
by DCC Technical Services. Please contact them at 615-794-2307 for assistance. 

 
Add a Group  Steps to Add a New Group: 
 1. Click the Groups tab to bring this screen to the front. 

 2. Click New.  The Group Information dialog box displays. 

 3. At Name, type a title for the new Group. 

 4. Make desired changes if they differ from the default settings: 
 International Format 
 Long Distance Format 
 Local Format 
 Extension Format 
 Add Ext Format 
 Unknown Format 
 Valid Digits  

 5. Click OK to save the changes and return to the Groups tab.  Click Cancel to abort the action. 

 6. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 74: At the 
Advanced Dialing Rules 
screen, click the Groups tab 
to bring this screen to the 
front.  Click New to display 
the Group Information 
dialog box.  At the Name 
field, click to select the field 
and type a name for the 
group.  Makes changes to 
the other fields as desired, 
and then click OK to return 
to the Advanced Dialing 
Rules screen. 
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Edit a Group Steps to Edit a Group: 

 1. Click the Groups tab to bring this screen to the front. 

 2. Click to select the desired group from the listing.   

 3. Click Edit.  The Group Information dialog box displays. 

 Note:  The group Name cannot be changed.   If the name needs to be changed, delete the group and 
recreate it with the new name. 

 4. Make desired changes to the following settings:  
 International Format 
 Long Distance Format 
 Local Format 
 Extension Format 
 Add Ext Format 
 Unknown Format 
 Valid Digits  

 5. Click OK to save the changes and return to the Groups tab.  Click Cancel to abort the action. 

 6. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 75:  At the 
Advanced Dialing Rules 
screen, click the Groups tab 
to bring this screen to the 
front.  Select the group to be 
edited, and then click Edit 
to display the Group 
Information dialog box.  
Make changes to the fields 
as desired, and then click 
OK to return to the 
Advanced Dialing Rules 
screen.  
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Delete Groups Steps to Delete Groups: 

 1. Click the Groups tab to bring this screen to the front. 

 2. Click to select the desired groups from the listing.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent items, 
Shift + Click to select a range of items or use a combination of the two methods. 

 3. Click Delete.  The Confirm delete dialog box displays. 

 4. Click Yes to delete the selected groups or No to cancel the action. 

 5. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration screen. 

 
Figure 76:  At the Groups 
tab located in the Advanced 
Dialing Rules window, 
click to select the groups to 
delete.  Click the Delete 
button.  The Confirm 
delete groups dialog box 
displays.  At the ‘Do you 
really want to delete the x 
groups?’ message, click 
Yes to delete the selected 
groups. 
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Export Groups Steps to Export Groups: 

 1. Click the Groups tab to bring this screen to the front. 

 2. Click to select the desired groups from the listing.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent items, 
Shift + Click to select a range of items or use a combination of the two methods. 

 3. Click Export.  The Export x groups dialog box displays. 

 4. Click . The Select a file for exporting screen displays. 

 5. Select the desired drive and folder at the Look in field. 

 6. At File name, click to select the text box and type a file name.  The file can be saved as a *.csv or *.txt 
file type. 

 7. Click Open.  The export file path will display in the Export File field at the Export Groups box. 

 8. Click Export.  When the export process has successfully completed, a message will display stating 
‘Export successful. Finished exporting x records.’ 

 9. Click OK at the confirmation box. 

 10. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 77:  At the Groups 
tab located in the Advanced 
Dialing Rules window, click 
to select the groups to export.  
Click the Export button.  
Click the search button. 
Select the drive/folder option 
at the Look in field, type a file 
name at the File name field, 
and then click Open.  At the 
Export x groups box, click 
Export. At the confirmation 
message, click OK. 
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Import Groups Steps to Import Groups: 

 1. Click the Groups tab to bring this screen to the front. 

 Note:  Import files can be a *.txt or *.csv file format. 

 2. Click Import.  The Import Groups box displays. 

 3. Click . The Select a file for importing screen displays. 

 4. Select the desired drive and folder at the Look in field. 

 5. Click to select the desired file. 

 6. Click Open.  The import file path will display in the Import File field at the Import Groups box. 

 7. Click Import. When the import process has successfully completed, a message will display stating 
‘Import successful Processed x out of x records. Saved x records.’ 

 8. Click OK to close the confirmation box. 

 9. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 78:  At the Groups 
tab located in the Advanced 
Dialing Rules window, click 
the Import button. At the 
Import Groups box, click 
the search button.  The Select 
groups file to import dialog 
box displays.  Select the 
drive/folder option at the 
Look in field, select the file 
name, and then click Open.  
At the Import Groups box, 
click Import. At the 
confirmation message, click 
OK. 
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Dialing Rules Tab 
 Dialing Rules enable you to change the dialing instructions for calls in the same country or area. 

For example, this may be necessary when some numbers in a city/area code are local and others 
are long distance, or when some areas use 10-digit local dialing and others use 9-digit dialing, or 
outside lines are accessed differently from a PBX for different locations, etc. The best strategy is 
to create general rules that cover most of the dialing, and then more specific rules that cover the 
exceptions (see below). 
The Dialing Rules tab is used to create, edit, delete, import or export advanced number dialing 
options. The dialing rules listing consist of the Group name, Number, Dial Format, Call Type 
and Cost. 

 Note:  This information is provided for informational purposes only. Line Configuration is preformed 
by DCC Technical Services. Please contact them at 615-794-2307 for assistance. 

 
Country City Subscriber Description 
1 * * Very General rule – all calls are long distance 
1 615 * General rule – all local calls in the 615 area code 
1 931 * General rule – all local calls in the 931 area code 
1 615 555* Specific rule to cover the exceptions – only 615-555* are long 

distance 

    
Steps to Add a New Dialing Rule: Add a Dialing Rule 
1. Click the Dialing Rules tab to bring this screen to the front. 

 2. Click New.  The Number Dialing Rule dialog box displays. 

 3. At Country, click to select the text box and type the country number. For example, type a 1 to access a 
long distance operator for the United States. 

 4. At City, click to select the textbox and type the 3-digit area code number. 

City The City number is the 3-digit area code. The * (asterisk) wildcard character can be used to represent 
ALL. For example, a dialing rule can be created to cover all numbers dialed within an area code by 
entering the 3-digit area code in the City field 615, and then using an * in the Subscriber field. This rule 
will then cover all number’s dialed within this City code unless there are more specific rules (e.g., 1-615 
555*) needed to address exceptions. 

 5. At Subscriber, click to select the textbox and type the subscriber number. 

Subscriber The Subscriber number is defined as the digits that follow the city/area code. In the U.S., this number 
consists of a 3-digit exchange plus a 4-digit number (e.g., 555-5555). The * (asterisk) wildcard 
character can be used to represent ALL. For example, if the entries are City=615 and Subscriber=555*, 
only numbers dialed within the 555 exchange will be covered by this dialing rule. 

 6. At Extension, click to select the textbox and type the extension number. 

Extension The Extension number is any numbers that follows the Subscriber number. You can also use the * 
(asterisk) wildcard character to represent ALL.  

 7. At Group, click  and select a group if different than the Default group. 

 8. At Cost, click to select the textbox and type the Cost. 

 continued… 
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Cost The Cost value is used in conjunction with the selected Number Type to describe the relative difficulty 

to send this call and determine which lines have preference to send the call. The values can range from 
0 to 9999. The lower the number, the more the system will use that line to send the call. If the cost is 
prohibitive (9999), then the system will never use that line to place a call. The system defaults to 0 for 
Extension, 10 for Local, 100 for Long Distance and 1000 for International. The cost 9999 is reserved 
for ‘too expensive to send’. If you configure dialing rules for numbers with different cost across groups, 
the number would go to the group with the lowest cost. If there were not any lines available, the call 
would go to the next lowest cost group.  

 Example: In a geographic area where: 

 Some lines call the 615 area code as long distance  (16156662882x5555) with assigned Cost = 100 
 Some lines can make that same call as a local call. (6662882x5555) with assigned Cost = 10 
 Some lines are hooked into a local PBX and can make the call by dialing an extension (555) with assigned 

Cost = 0 
The engine uses the Cost field to determine which lines have preference to send the call. In this case, it will use the 
PBX line first.  If that line is busy, it will use the local line.  If that line is also busy, it will use the long distance line. 

 9. At Number Type, click to select the radio button corresponding to the entered Cost – International, 
Long Distance, Local or Extension. 

 10. At Use this dial format, click to select the check box then type the new dialing format in the text box 
provided (e.g., T9 where T specifies wait for tone, then dial the number 9, etc.). 

 11. Click Save and Close to save the new group, close the Number Dialing Rule dialog box and return to 
the Advance Dialing Rules window.  Click Save and New to save the new dialing rule, clear the 
Number Dialing Rule dialog box and create a new dialing rule.  Click Cancel to abort the action.   

 12. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 79:  At the 
Advanced Dialing Rules 
screen, click the Dialing 
Rules tab to bring this 
screen to the front.  Click 
New to display the Number 
Dialing Rule dialog box.  
Enter information, as 
desired in the Country, City, 
Subscriber, Extension, and 
Group fields.  Click Save 
and Close to return to the 
Advanced Dialing Rules 
screen. 
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Steps to Edit a Dialing Rule: Edit a Dialing 

Rule 1. Click the Dialing Rules tab to bring this screen to the front. 

 2. Click to select the desired dialing rule from the listing.   

 3. Click Edit.  The Number Dialing Rule dialog box displays. 

 4. At Country, click to select the textbox and type the country number. For example, type a 1 to access a 
long distance operator for the United States. 

 5. At City, click to select the textbox and type the 3-digit area code number. 

City The City number is the 3-digit area code. The * (asterisk) wildcard character can be used to represent 
ALL. For example, a dialing rule can be created to cover all numbers dialed within an area code by 
entering the 3-digit area code in the City field 615, and then using an * in the Subscriber field. This rule 
will then cover all number’s dialed within this City code unless there are more specific rules (e.g., 1-615 
555*) needed to address exceptions. 

 6. At Subscriber, click to select the textbox and type the subscriber number. 

Subscriber The Subscriber number is defined as the digits that follow the city/area code. In the U.S., this number 
consists of a 3-digit exchange plus a 4-digit number (e.g., 555-5555). The * (asterisk) wildcard character 
can be used to represent ALL. For example, if the entries are City=615 and Subscriber=555*, only 
numbers dialed within the 555 exchange will be covered by this dialing rule. 

 7. At Extension, click to select the textbox and type the extension number. 

Extension The Extension number is any numbers that follows the Subscriber number. You can also use the * 
(asterisk) wildcard character to represent ALL.  

 8. At Group, click  and select a group if different than the Default group. 

 9. At Cost, click to select the textbox and type the Cost. 

Cost The Cost value is used in conjunction with the selected Number Type to describe the relative difficulty to 
send this call and determine which lines have preference to send the call. The values can range from 0 to 
9999. The lower the number, the more the system will use that line to send the call. If the cost is 
prohibitive (9999), then the system will never use that line to place a call. The system defaults to 0 for 
Extension, 10 for Local, 100 for Long Distance and 1000 for International. The cost 9999 is reserved for 
‘too expensive to send’. If you configure dialing rules for numbers with different cost across groups, the 
number would go to the group with the lowest cost. If there were not any lines available, the call would 
go to the next lowest cost group.  

 Example: In a geographic area where: 
 Some lines call the 615 area code as long distance  (16156662882x5555) with assigned Cost = 100 
 Some lines can make that same call as a local call. (6662882x5555) with assigned Cost = 10 
 Some lines are hooked into a local PBX and can make the call by dialing an extension (555) with assigned 

Cost = 0 
The engine uses the Cost field to determine which lines have preference to send the call. In this case, it will use the 
PBX line first.  If the line is busy, it will use the local line.  If the line is also busy, it will use the long distance line. 

 10. At Number Type, click to select the radio button corresponding to the entered Cost – International, 
Long Distance, Local or Extension. 

 11. At Use this dial format, click to select the check box then type the new dialing format in the text box 
provided (e.g., T9 where T specifies wait for tone, then dial the number 9, etc.). 

 12. Click Save and Close to save the new group, close the Number Dialing Rule dialog box and return to 
the Advance Dialing Rules window.  Click Save and New to save the new dialing rule, clear the 
Number Dialing Rule dialog box and create a new dialing rule.  Click Cancel to abort the action.   

 13. Click OK at the Advanced Dialing Rules window to close it and return to the Line Configuration 
window. 
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Steps to Delete Dialing Rules: Delete Dialing 

Rules 1. Click the Dialing Rules tab to bring this screen to the front. 

 2. Click to select the desired dialing rule from the listing.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent 
items, Shift + Click to select a range of items or use a combination of the two methods. 

 3. Click Delete. The Confirm delete dialog box displays. 

 4. Click Yes to delete the selected dialing rule or No to cancel the action. 

 5. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 80:  At the Dialing 
Rules tab located in the 
Advanced Dialing Rules 
window, click to select the 
dialing rules to delete.  Click 
the Delete button.  The 
Confirm delete rules 
dialog box displays.  At the 
‘Do you really want to 
delete the x selected rules?’ 
message, click Yes to delete 
the selected dialing rule. 
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Steps to Export Dialing Rules: Export  Dialing 

Rules 1. Click the Dialing Rules tab to bring this screen to the front. 

 2. Click to select the desired dialing rule from the listing.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent 
items, Shift + Click to select a range of items or use a combination of the two methods. 

 3. Click Export.  The Export x rules dialog box displays. 

 4. Click . The Select a file for exporting screen displays. 

 5. Select the desired drive and folder at the Look in field. 

 6. At File name, click to select the text box and type a file name.  The file can be saved as a *.csv or *.txt 
file type. 

 7. Click Open.  The export file path will display in the Export File field at the Export x rules box. 

 8. Click Export. When the export process has successfully completed, a message will display stating 
‘Export successful. Finished exporting x records.’ 

 9. Click OK at the confirmation box. 

 10. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 81:  At the Dialing 
Rules tab located in the 
Advanced Dialing Rules 
window, click to select the 
dialing rules to export.  
Click the Export button. At 
Export x rules, click the 
search button. The Select a 
file for exporting dialog 
box displays.  Select the 
drive/folder option at the 
Look in field, type a file 
name at the File name field, 
and then click Open.  At the 
Export x rules box, click 
Export. At the confirmation 
message, click OK. 
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Import  Dialing 
Rules 

Steps to Import Dialing Rules: 
1. Click the Dialing Rules tab to bring this screen to the front. 

 Note:  Import files can be saved as a *.txt or *.csv file format. 

 2. Click Import.  The Import Rules box displays. 

 3. Click . The Select a file for importing screen displays. 

 4. Select the desired drive and folder at the Look in field. 

 5. Click to select the desired file. 

 6. Click Open.  The import file path will display in the Import File field at the Import Rules box. 

 7. Click Import. When the import process has successfully completed, a message will display stating 
‘Import successful. Processed x out of x records. Saved x records.’ 

 8. Click OK to close the confirmation box. 

 9. Click OK at the Advanced Dialing Rules window to close the window and return to the Line 
Configuration window. 

 
Figure 82:  At the Dialing 
Rules tab located in the 
Advanced Dialing Rules 
window, click the Import 
button.  At the Import 
Rules box, click the search 
button.  The Select a file for 
importing dialog box 
displays.  Select the 
drive/folder option at the 
Look in field, select the file 
name, and then click Open.  
At the Import Rules box, 
click Import. At the 
confirmation message, click 
OK. 
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Do Not Call List 

 

The Do Not Call List displays a listing of phone numbers that must not be called under any 
circumstances.  You have the ability to add phone numbers to the list, change existing numbers, 
import numbers, export numbers or delete numbers.   

  Note:  This information is provided for informational purposes only. Line Configuration is preformed 
by DCC Technical Services. Please contact them at 615-794-2307 for assistance. 

 
Steps to Add Numbers to the Do Not Call List: Add Numbers to 

the Do Not Call 
List 1. At the Line Configuration screen, click the Options menu, and then click Do Not Call (or click  

on the toolbar).  The Do Not Call window displays (the window will be blank unless numbers have 
been added). 

 2. Click New.  The Do Not Call This Number dialog box displays. 

 3. At Country, click the text box to select and type the country code (1 is for the USA). 

 4. At City, click to select the textbox and type the 3-digit area code number.  

 5. At Subscriber, click to select the textbox and type the subscriber number. 

 6. At Extension, click to select the textbox and type the extension number.  

 7. Click Save and Close to save the current number and close the Do Not Call This Number dialog box, 
click Save and New to save the current phone number and enter a new one or click Cancel to close the 
Do Not Call This Number dialog box without saving changes. 

 8. Click OK at the Do Not Call List window to close the window and return to the Line Configuration 
window. 

 
Figure 83:  To add a phone 
number to the Do Not Call 
List, click the Add button.  
The Do Not Call This 
Number dialog box 
displays.  Type information 
for the Country, City, 
Subscriber and Extension, 
and then click Save and 
Close.  The number is 
added to the Do Not Call 
List. 
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Steps to Edit Numbers in the Do Not Call List: 
1. At the Do Not Call This Number, click to select the phone number to edit. 

Edit a Number in 
the Do Not Call 
List 2. Click Edit.  The Do Not Call This Number dialog box displays. 

 3. At Country, click the text box to select and type the country code (1 is for the USA). 

 4. At City, click to select the textbox and type the 3-digit area code number. 

 5. At Subscriber, click to select the textbox and type the subscriber number. 

 6. At Extension, click to select the textbox and type the extension number. 

 7. Click Save and Close to save the current number and close the Do Not Call This Number dialog box, 
click Save and New to save the current phone number and enter a new one or click Cancel to close the 
Do Not Call This Number dialog box without saving changes. 

 8. Click OK at the Do Not Call List window to close the window and return to the Line Configuration 
window. 

 
Figure 84:  To edit a phone 
number in the Do Not Call 
List, click to select the 
phone number to change 
then click the Edit button.  
The Do Not Call This 
Number dialog box 
displays. Type information 
for the Country, City, 
Subscriber and Extension, 
and then click Save and 
Close. 
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Steps to Delete Numbers in the Do Not Call List: Delete Numbers in 

the Do Not Call List 1. Click to select the desired phone number from the listing.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent 
items, Shift + Click to select a range of items or use a combination of the two methods. 

 2. Click Delete.  The Confirm Delete dialog box displays. 

 3. Click Yes to delete the selected phone numbers or No to cancel the action. 

 4. Click OK at the Do Not Call List window to close the window and return to the Line Configuration 
window. 

 
Figure 85:  At the Do Not 
Call List window, click to 
select the phone numbers to 
delete.  Click the Delete 
button. The Line 
Configuration dialog box 
displays.  At the ‘You are 
about to delete x records. 
Continue?’ message, click 
Yes to delete the selected 
phone numbers. 
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Steps to Export Phone Numbers from the Do Not Call List: Export Numbers 

from the Do Not 
Call List 

1. Click to select the desired phone numbers from the listing to export.   

 Note:  Multiple items can be selected by using the following: Ctrl + Click to select non-adjacent 
items, Shift + Click to select a range of items or use a combination of the two methods. 

 2. Click Export.  The Export Do Not Call Addresses box displays. 

 3. Click . The Select a file for exporting screen displays. 

 4. Select the desired drive and folder at the Look in field. 

 5. At File name, click to select the text box and type a file name.  The file can be saved as a *.txt or *.csv 
file type. 

 6. Click Open.  The export file path will display in the Export File field at the Export Do Not Call 
Addresses box. 

 7. Click Export.  When the export process has successfully completed, a message will display stating 
‘Export successful. Finished exporting x records.’ 

 8. Click OK.  The phone numbers have been exported to a .txt  or .csv file. 

 9. Click OK at the Do Not Call List window to close the window and return to the Line Configuration 
window. 

 
Figure 86:  At the Do Not 
Call List window, click the 
Export button At Export 
Do Not Call Addresses, 
click the search button. The 
Select a file for exporting 
dialog box displays.  Select 
the drive/folder option at the 
Look in field, type a file 
name at the File name field, 
and then click Open.  At the 
Export Do Not Call 
Addresses box, click 
Export. At the confirmation 
message, click OK. 
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Steps to Import Phone Numbers to the Do Not Call List: Import Numbers to 

the Do Not Call 
List 1. Click Import.  The Select rules file to import dialog box displays. 

 Note:  Import files can be saved as a *.txt or *.csv file format. 

 2. Click Import.  The Import Do Not Call Addresses dialog box displays. 

 3. Click . The Select a file for importing screen displays. 

 4. Select the desired drive and folder at the Look in field. 

 5. Click to select the desired file. 

 6. Click Open.  The import file path will display in the Import File field at the Import Do Not Call 
Addresses box. 

 7. Click Import.  When the import process has successfully completed, a message will display stating 
‘Import successful. Processed x out of x records. Saved x records.’ 

 8. Click OK. The imported phone numbers display in the Do Not Call List. 

 9. Click OK at the Do Not Call List window to close the window and return to the Line Configuration 
window. 

 
Figure 87:  At the Do Not 
Call List window, click the 
Import button.  At the 
Import Do Not Call 
Addresses box, click the 
search button.  The Select a 
file for importing dialog 
box displays.  Select the 
drive/folder option at the 
Look in field, select the file 
name, and then click Open.  
At the Import Do Not Call 
Addresses box, click 
Import. At the confirmation 
message, click OK. 
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Access a Different Machine 
 The Machine option at the Options menu allows you to access an RxT database on a different 

machine.   Note that the Options menu also displays the machine name of the ten most recent 
successful database connections.  

 
Steps to Access a Different Machine:  

1. At the menu, click Options > Machine. The Connect to machine screen displays. 
 2. At Machine name, type the name, and then click OK.  The system will then connect to the RxT 

database on that machine. 

 Note:  The Options menu also displays the machine name of the ten most recent successful database 
connections. You can switch to a machine’s RxT database by clicking the displayed machine name. 

 
Figure 88:  To access an 
RxT database on a different 
machine, click Options > 
Machine.  At Machine 
name, type the name, and 
then click OK.    
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Exit the Line Configuration Application 

 
To close the Line Configuration application, select Exit from the File menu or select the close 
icon located on the upper right of the title bar. 

 
Steps to Exit the Line Configuration Application:  

1. At the Line Configuration screen, click the File menu then click Exit (or click  on the upper right 
of the title bar. 

 
Figure 89:  To exit the Line 
Configuration application, 
click the close button on the 
upper right of the title bar or 
select File > Exit. 
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